AnsweredAssumed Answered

PN7462AU not waking up after standby

Question asked by Midhun V R on Apr 4, 2019
Latest reply on Apr 16, 2019 by Martin Elshuber

Hi ,

 

We are having issues related to wake up in PN7462AU. This issue is observing in our certain boards and in some other issue is not observed. It seems like device is not waking up after standby call is called. The issue is observed with Door access sample application also.In sample application , we enabled the "PHFL_ENABLE_STANDBY" macro and started running. The polling stops after few seconds due to wakeup issue. Tried to debug the issue using some GPIO toggling and found that after standby call , code is not executing further and not waking up either after timer expiry.

 

PH_REG_SET_BIT_WO(PCR_CTRL_REG,STANDBY);
/* This portion of the code will be reached only when entering into the standby fails */
dwStbyPrevReason = PH_REG_GET(PCR_BOOT_REG);
*psStandbyPrevReason = (phhalPcr_StandbyPrevReason_t)
((dwStbyPrevReason & PCR_BOOT_REG_STBY_PREV_REASON_MASK) >> PCR_BOOT_REG_STBY_PREV_REASON_POS);

 

In the above section , code is running upto 'PH_REG_SET_BIT_WO(PCR_CTRL_REG,STANDBY);' . Below code is not executed. But device is not waking up after timer expiry (500mS) . Also when current consumption is measured , it is around 10mA and seems like device is not in standby.

 

We tried checking EEPROM values and looks OK.

Also when standby is disabled , issue is not present.

 

Can anybody help us in this ? 

Also is there a better way to debug this ? Since the firmware have standby included , after the standby call  debugger shows error.

 

Thanks in advance

Midhun

 

Outcomes