AnsweredAssumed Answered

I get an error trying to import the SDK for i.MX8 Quad Max: The SDK 'SDK_2.x_MEK-MIMX8QM' does not contain any MCUXpresso IDE compatible toolchain.  Can someone help me on this?

Question asked by Peter Lombrozo on Aug 29, 2018
Latest reply on Aug 30, 2018 by jamesbone

I have the latest MCUXpresso.  The full error text:

 

 

eclipse.buildId=unknown
java.version=1.8.0_161
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
Command-line arguments: -os win32 -ws win32 -arch x86

com.nxp.mcuxpresso.core.datamodels
Error
Tue Aug 28 15:21:06 PDT 2018
The SDK 'SDK_2.x_MEK-MIMX8QM' does not contain any MCUXpresso IDE compatible toolchain.

at com.nxp.mcuxpresso.core.datamodels.providers.SDKManifestProvider.addToMap(SDKManifestProvider.java:830)
at com.nxp.mcuxpresso.core.datamodels.providers.SDKManifestProvider.access$0(SDKManifestProvider.java:817)
at com.nxp.mcuxpresso.core.datamodels.providers.SDKManifestProvider$3.preVisitDirectory(SDKManifestProvider.java:615)
at com.nxp.mcuxpresso.core.datamodels.providers.SDKManifestProvider$3.preVisitDirectory(SDKManifestProvider.java:1)
at java.nio.file.Files.walkFileTree(Files.java:2677)
at java.nio.file.Files.walkFileTree(Files.java:2742)
at com.nxp.mcuxpresso.core.datamodels.providers.SDKManifestProvider.refresh(SDKManifestProvider.java:607)
at com.nxp.mcuxpresso.core.datamodels.SDKChipVendorDatabase.refresh(SDKChipVendorDatabase.java:672)
at com.nxp.mcuxpresso.core.datamodels.ui.views.SDKView.doDBRefresh(SDKView.java:1198)
at com.nxp.mcuxpresso.core.datamodels.ui.jobs.SDKImportJob.run(SDKImportJob.java:95)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:56)

Outcomes