AnsweredAssumed Answered

Suspend issue with 1DX module from Murata based on CYW4343W chipset

Question asked by Ashish Agraval on Sep 20, 2017
Latest reply on Sep 26, 2017 by Ashish Agraval

We are using Murata LBEE5KL1DX (BCM4343W) as Wi-Fi module with i.MX6ULL. We have been able to compile BCMDHD driver for this chip inbuilt (in kernel) successfully and are able to use it. But while putting system in sleep mode (echo mem > /sys/power/state), sometimes system refuse to go in to sleep mode (Error: mmc1: resource busy -16). We tried to down/up Wi-Fi wlan0 interface but still system refuse to go in to sleep mode. We tried to debug this in to code and suspect that this is due to some wake-lock related issue. At some point of time, Wi-Fi driver takes wake-lock (this is different that standard wake-lock being used in Android) and before it unlocks the same, user space application tries to put system in to sleep mode. Any pointer - how use user space application come to know about status of this wake-lock / how can this lock can be unlocked ?

 

We have tried to trace down the code to debug the issue as per our understanding. Wake lock may not be a reason for this observation. Can you please share your thoughts/suggestion to move ahead in this?

 

Ashish

Outcomes