AnsweredAssumed Answered

LPC5411x  - Boot loader with In-System Programming (ISP) over USB issue?

Question asked by robbc on Oct 27, 2016
Latest reply on Oct 27, 2016 by robbc

I just got the LPC5411x dev board (OM13089) and was trying to program the micro using the boot mode ISP feature over USB.  I followed the procedures on UM10973 - section 9.2 and it worked successfully when Vdd is 3.3V.  

 

The board has a selectable Vdd option of 1.8V or 3.3V using J9.  If I switch to Vdd = 1.8V and try and the same boot procedure using USB, it does not work.  If I replace the jumper and switch back to Vdd = 3.3V the device is recognized and I can see it on my computer.  

 

I have 2 boards and the both behave the same.

 

Questions:

 1) Has anyone tried this or seen the same behavior? Is it specific to the dev board or to the micro?

2)Do you need 3.3V to enter ISP boot mode over using USB and flash? Is this documented somewhere?

3) I would like to power everything with 1.8V –what are my options if I want to still flash over USB?

Outcomes