AnsweredAssumed Answered

SPI DMA Clock spike

Question asked by Maximilian Niedernhuber on Aug 17, 2016
Latest reply on Aug 17, 2016 by Maximilian Niedernhuber


the disable of the SPI causing a high and the enable causing a low on the spi clock line.


status_t SPI_MasterTransferDMA(SPI_Type *base, spi_dma_handle_t *handle, spi_transfer_t *xfer) {


     /* Disable SPI and then enable it, this is used to clear S register*/

    SPI_Enable(base, false);

    SPI_Enable(base, true);




My spi slave recognise this a one clock cycle. I think this is a bug in KSDK2.0.


Best regards