AnsweredAssumed Answered

Why is my K64F unable to connect?

Question asked by Michael Koller on Jul 27, 2016
Latest reply on Jul 28, 2016 by Michael Koller

Hey there!

 

I haven't used my FRDM K64F for a few weeks and now I cannot connect it to my laptop via the USB host any more.

I'll first describe the current behavior:

If I connect the OpenSDAv2 Micro USB port, nothing happens. If I press reset, I can see the Bootloader device in my explorer and the green status light is blinking slowly. (Pressing and holding the reset button and then plugging in the OpenSDA seems to be the standard way to get into the bootloader). When I connect to the other USB port, the red status light is on permanently.

 

Did the following thing maybe do damage:

I connected Pin 16 (P5-9V_VIN) to 5V and Pin 12/14 (both GND) to my Ground. Then the green and red status lights flashed very fast. The second time it did not work anymore with this way of powering the board, only the red status light again. Afterwards I tried to connect and power the board to my laptop, as usually, but it only shows the behavior I mentioned above.

 

The constant red light means it is resetting all (I've read).

 

When I last used the board with the Kinetis Design Studio, everything worked fine.

 

Did I brick it somehow? How can I recover it?

I am reading the 'Getting Started with the Kinetis ROM Bootloader User Guide'. Is this the right source?

 

Thanks for all information and help in advance!

Cheers,

Michael

 

PS: I am reading similar threads that have a similar topic, like this one: https://mcuoneclipse.com/2014/11/10/recovering-the-frdm-k64f-bootloader-or-cloning-the-program-of-a-microcontroller/

But I really do not want to make things worse without having talked to someone with expertise here on the forum first.

Outcomes