lpcware

LPC1756 USB Communication works only during programming every time in VECTRESET mode

Discussion created by lpcware Employee on Jun 15, 2016
Content originally posted in LPCWare by sathyan on Wed Apr 23 03:27:23 MST 2014
Hello!

I have brought LPC1756 Chips and made a custom board for it.

I tried to program the chip using the LPC1768 sample codes.

I am able to get the output for basic GPIO, UART Programs. But, when i tried communicating with USB Mass Storage, I am getting a weird problem.

After flashing the code using CoFlash tool configured in VECTRESET, i am able to send and recieve data through the usb of LPC1756. but when i reset the chip, i am unable to communicate with the USB! the program halts at Write Done Back Head Interrupt! But still on every reset i am able to get the outputs from UART and other GPIO but not from the USB!

Then i tried configuring the CoFlash tool in VECTRESET and clicked on blank check, then i am able to send and recieve data through USB!

But i cannot do this every time for a standalone device.

Please help me why am i not able to communicate through USB when the configuration is in SYSRESETREQ/HWRESET?

Why am i getting output only once for every program/blank check while the configuration is in VECTRESET?

Why does the reset button works only for the UART/GPIO and not the USB?

It seems like the memory map is simillar to both LPC1756 and LPC1768 for the UART and USB. Where am i making mistake?

please help!

Regards,
Sathyan

Outcomes