AnsweredAssumed Answered

Can anyone create a simple working project for me?

Question asked by Rande Newberry on Feb 24, 2016
Latest reply on Feb 25, 2016 by Rande Newberry

I posted the below earlier because the project was running so I marked it as solved..but the error is back again. but this time a little different..

First, I know it was running because I added the code to make a variable = to 10 if it was 0 (initial state), and it worked..BUT...

The Debug failed with the same error (No source available for "0x4d8") after I used Processor expert to create 1 input and 1 output.

The difference now is that when the debugger starts it does stop at a "temporary break point" and provides the green resume button to continue..

I am wondering if anyone can send me a simple example..maybe toggle an LED on PTD7 (that is what I was trying to do),

Also I noticed the attachments I included in the original did not show up in the discussion, any advice on how to include an attachment would be helpful.

 

Thank you

 

BELOW IS ORIGINAL POST..

My Coder retired, and I'm taking over for now..I'm new to C, but OK with assembler.

I'm using: KDS3.0.0 and SDK 1.3.0, Win8 machine, debugging with a P&E Mutlilink Universal, with SWD

I was left with a working project using an MK20DX128VLH7_QFP64, which I can run, edit and debug with no problems, so I feel confident the tools are OK.

My new project:is a custom PCB uses an MK02FN64VLH10_QFP64

Problem is I can not create a simple project without getting the error:  No source available for "0x4d8" in what looks like a C file when I try to debug.

Here are the steps I used to create a new project:

Created new Kinetis project, Named it SR3kD, kept default location. Clicked next

Selected processors> Kinetis K >MK0x > MK02FN64xxx (my processor is MK02FN64VLH10, in a QFP64 pin package) Clicked Next

Kept defaults: KSDK_1.3.0 and Absolute path checked, Selected Processor Expert, kept defaults: use current perspective and Standalone Clicked Next

Kept Default GNU C compiler Clicked Finish.

 

I modified Main.c by un-commenting out the endless loop example:

/* Write your code here */

for(;;) { }

 

Compiled the project, no errors

 

Selected Debug Configurations > GDB PEMicro…> Highlighted SR3kD_Debug_PNE (I am using a P&E Multilink Universal)

Then click the Debug button at the bottom.

 

The debugger launched and ran (I did not need to click the green resume arrow..)

Program appears to be running: except the Red message No Source available “0x4d8, in a “c” file of the same name.  Attached PIC 1

I put a break point at my endless "for loop" in Main.c…never gets there.

When I pause the program, it crashes.

No resume, no Pause, no steps..Attached PIC2.

 

Can anyone help here?

 

Message was edited by: Rande Newberry After a dozen or so attempts since I posted this, using the same project, the debugger locked up, and I was not able disconnect or anything, so I closed the project, reopened it, and was able to "remove all disconnected" that was still in the debug window, launched debug (just clicking the bug), it said no recent launches, (which was a new message..first time I seen this) and it did not start the debugger.So I used the Debug configurations window, and its now worked! I've been at this for days, have no clue what caused it to start working. temporally same problem came back after I used Processor Expert to add 1 input and 1 output port..

Outcomes