AnsweredAssumed Answered

JN5168-M05

Question asked by Liam Hayes on Jan 18, 2016
Latest reply on Sep 11, 2017 by Adam Jacob

I have just started using a high powered JN5168-M05 for a project. Whilst it is running and sending out debug information the radio does not seem to be working at all. It does not link to a coordinator, and when it does an energy scan (as a coordinator) all the energies come back as 0.

 

I am using it in basic IEEE15.4 mode.

The same code works find on a M00 module.

I have called

vAppApiSetHighPowerMode( APP_API_MODULE_HPM05, TRUE ) before using radio.

I am using it with an external 2dB dipole antenna.

 

I have downloaded the NXP JN-AP-1172 JN516x Customer Module Evaluation Tool. I've compiled it in BeYond Studio with the latest SDK.

The results are similar : When I run it on a M00 and do the receive test or RF power measurement test I can see activity on the channels.

When I run the same binary (and enable high power mode from the terminal) on a M05 the channels are completely silent.

 

Its like the radio is not switched on in the M05.

I have tried two M05.

I have used the M00 module extensively without issue.

Antenna is not shorted or anything like that.

 

Has anyone got an M05 working? Any ideas what I could be doing wrong?

 

Thanks in advance for any help.

Outcomes