AnsweredAssumed Answered

No source available for "0x0" -- execution stops at __isr_vector()

Question asked by dave408 on Oct 20, 2015
Latest reply on Oct 23, 2015 by dave408

I have read the existing post No source available for "__isr_vector() at 0x0" but the solution there did not work for me, so I am really hoping that someone here has some debugging tips for me!

 

My current firmware (developed under KDS 3.0 with KSDK 1.2) was generally working fine, but today I had to add another OS_Task.  It is during debugging of this task that I ran into trouble, including this problem where my code stops executing and all I see is this:

 

 

I thought that maybe it was a task stack size issue, but I have increased the stack size already.  The code fails roughly at the same point every time.


I know that I am not having a power supply problem.  I did find it strange that every time this error occurs, I have to unplug my Segger J-Link, or upon the next execution attempt, it will not see the debugging device.  I originally had it plugged into my monitor, so I switched to my front USB ports.  When that didn't work, I tried my rear USB port through a powered USB hub.  I still have the same problem.

 

The place where execution stops is really weird.  It's when I assign NULL to a member variable:

Seems innocuous enough to me.

 

Can anyone recommend other things to try here?  I'm going to try reverting the code back a little and running some tests outside of the task to see what happens.

 

EDIT - I removed the task and reran code that used to work, and it now fails when evaluating a simple for loop.  I'll probably have to revert my entire codebase now -- maybe there's something in the shared classes that is screwing up everything...

Outcomes