AnsweredAssumed Answered

Debugger code load problem on QORIQ Converge B4860 EVM(B4860QDS)

Question asked by NIKUNJ TAPODHAN on Jun 2, 2015
Latest reply on Jun 18, 2015 by lunminliang

Hi,    Currently I am using A QORIQ Qonverge B4860 EVM Board for dsp  code development. I want to now start on debugging my Code modules.  

Background is that Freescale board is able to connect to PC using code warrior IDE, but I  am not able to download the code in dsp using debug mode.

 

I am using on board ecwtap configuration to launch the debugger  and no external Probes are used in setup. ECWTAP configuration, board connection is verified successfully as mentioned in the steps in below thread:

I have tried to see and configure the CCS as per following thread:

Getting started with B4860QDS Board 'out of the box'

After doing this, I am able to connect to board.In general it looks like I am able to connect to board but loading the code in debugger is not working out..

 

I have tried "Download", "Attach" debug configurations for launching  code in target using the onboard eCWTap(codewarrior tap in usb  configuration) ,i referred the quick reference and description guides to  solve the issues, tried lots of things but did not work.  NOTE: We are not using external debug devices such as codewarrior  tap or USB Tap, we are simply connecting a USB Cable to J2 usb  connector on board for debugging.  The error I am facing is that I am not able to debug any code in this  EVM and whenever I load any elf it does not halt at main()(stepping  through the code is not possible), Program counter gets stuck  somewhere at 0x00000002..and throws error.  I have attached the screenshot for reference. 

 

 

Please help

 

regards

nikunj

Attachments

Outcomes