AnsweredAssumed Answered

Building a MQX Standard project with PE and KSDK

Question asked by Brian Hight on Feb 11, 2015
Latest reply on Feb 17, 2015 by Brian Hight

I am trying to build a project for the TWR-K60 board using KDS 2.0, KSDK 1.1 with a MQX Standard RTOS.

 

This is the flow I am following...

1. Create new KDS project.

2. Choose the board.

3. Select Kinetis SDK, enable Processor Expert and choose Standalone mode.

4. Change OSA component from bare metal to MQX KSDK (this chooses MQX Lite by default)

5. Fix the clocks for the processor (delete default clock configs 2-4 since they can't support the desired UART rates)

6. Change the settings for the DebugCs1 fsl_debug_console to use UART5 at 115,200 (this is the OSJTAG debug output)

7. Config other peripherals and pins.

8. Generate the PE code.

9. Build the project.

 

This all works fine.

 

However, if I try to change the RTOS to MQX Standard from Lite, a couple things occur.

First, I have to delete the DebugCs1 console.  MQX Standard doesn't seem to be able to share the UART with the other drivers.

I have tried to set the MQX Standard debug to UART5 and DebugCs1 to a different UART, but I still get the error.

I also have to add at least one MQX task before generating the PE code.

I can generate the PE code, but building the project results in about 40 errors.  It seems like the code is trying to assert portions of the DebugCs1 UART without it being there.

 

Has anyone else run into this?  Any workarounds?

 

Thanks.

Outcomes