AnsweredAssumed Answered

Kinetis KL05 SWD Connectivity Problems

Question asked by Bryan Olinger on Jan 3, 2015
Latest reply on Jan 5, 2015 by Santiago_Lopez

We have first hardware boards and simply can not communicate with it

 

Our setup:

 

Keil MDK version 5.12

Seggar J-Link v8.0

Seggar driver v4.86b

 

J-Link

20 pin header     KL05 32-pin QFN (FM)

----------                 --------

1 (Vcc)                 board Vcc

7 (SWD_DIO)     32 (PTA2/SWD_DIO) with a 51k pullup

9 (SWD_CLK)    30 (PTA0/SWD_CLK)

15(Reset)            31 (PTA1/ /RESET)  with a 4.7k pullup

20(GND)              board GND

 

We can see SWD clock and data transitioning cleanly.  The reset line has an odd sawtooth waveform on it (see attached photo), but we are being told this is expected.

 

See the attached a screen shot of the Keil debug settings.   We can't find any documentation that these are the correct "Connect and Reset Options".   Can someone confirm that this is correct?

 

To confirm it wasn't an issue with the development environment and tools, we connected to a different non-Kinetis ARM board

and had no issues communicating to the device via SWD. 

 

We also attempted to connect to the KL05 board using IAR Embedded Workbench 7.30.  Same result.  We could not communicate with the KL05.

 

To ensure it wasn't an issue of the latest tools being needed, we used a different computer to install the latest Keil (5.13) and Seggar drivers (4.96).  Same result.  We could not communicate with the KL05.

 

Has anyone else seen this issue with the Kinetis KL05?

 

Keil Debug Settings.jpg

 

KL05 Reset Line Scope Shot.jpg

Outcomes