AnsweredAssumed Answered

MM912J637 - is it possible to prgram them so VDDX doesn't startup?

Question asked by Ian Wilson on Sep 11, 2014
Latest reply on Sep 23, 2014 by Alexis Adenot

Hi all,

 

We are finding a significant proportion of our MM912J637 devices not programming. It is possibly as high as 1 in 10.

 

Some of the failing devices are brand new and some of them have been programmed before.

 

When I debug them I find that the VDDX power supply has not started up. RESET and RESET_A are both low - but this is not surprising if the supplies are off.

 

I have tried waking them up using the PTB3 input - no go.

 

An earlier design revision programmed just fine.  Both this earlier design and this particular iteration has a small issue where the BKGD/MODC is pulled up to a separate 5V supply which could rise slightly (a few ms) earlier or later than the VDDX supply. But this has not caused issues in the past (and this is now fixed in a forthcoming spin of the design).

 

What could stop VDDX starting up after initial power up?

Could software cause such a lock up?

Could some programming procedure cause such a problem?


We are using a P&E Multilink Universal and also a P&E Cyclone Pro (in both USB and Standalone modes). Both perform the same.  I have tried unsecuring the parts but the programmers can find these "bricked" units; but have no trouble finding a normal device.


The Cyclone Pro reports a 0x0005 0x000C timing error when it attempts to program one of these bad devices.

 

many thanks,

Ian

 

Message was edited by: Ian Wilson

Outcomes