AnsweredAssumed Answered

imx6 GPU 2D/3D acceleration not working in Yocto qte-in-use-image

Question asked by 2gigeng on Jul 11, 2013
Branched to a new discussion

The GPU 2D/3D acceleration is not working in the Yocto qte-in-use-image.  Looks like the "virtual/libgles2" and "-opengl es2 -openvg" are missing from imx6 in files qt4-embedded_4.8.4.bbappend and qt4-x11-free_4.8.4.bbappend, as shown below.

 

     DEPENDS_append_mx5 = " virtual/kernel virtual/libgles2"
     PACKAGE_ARCH_mx5 = "${MACHINE_ARCH}"
     QT_GLFLAGS_mx5 = "-opengl es2 -openvg"
     QT_CONFIG_FLAGS_append_mx5 = " -I${STAGING_KERNEL_DIR}/include/"

 

     DEPENDS_append_mx6 = " virtual/kernel"
     PACKAGE_ARCH_mx6 = "${MACHINE_ARCH}"
     QT_CONFIG_FLAGS_append_mx6 = " -I${STAGING_KERNEL_DIR}/include/"

 

Adding "virtual/libgles2" and "-opengl es2 -openvg" for the imx6 as below resulted in the attached build errors.

 

     DEPENDS_append_mx6 = " virtual/kernel virtual/libgles2"
     PACKAGE_ARCH_mx6 = "${MACHINE_ARCH}"
     QT_GLFLAGS_mx6 = "-opengl es2 -openvg"
     QT_CONFIG_FLAGS_append_mx6 = " -I${STAGING_KERNEL_DIR}/include/"

 

What is the correct way to enable GPU 2D/3D acceleration for imx6 in the Yocto qte-in-use-image?

Original Attachment has been moved to: log.do_configure.951.zip

Outcomes