AnsweredAssumed Answered

How to make the customized toolchain work with Ltib

Question asked by jun sun on Jun 14, 2013
Branched to a new discussion

Hello all ,

 

I met a strange problem when i use Ltib and customized linaro tool chain to build my project.

To my project, i need to use newer linaro toolchain to replace the gcc-4.6.2 (glibc2.13).

After i modify the configure option [ Toolchain , ToolchainPath and CFLAGS) and rebuild my project, i found the compile process is halted at .Processing: base_libs. Before that, the linux kernel is compiled successfully.

 

Processing: base_libs

=======================

Build path taken because: no prebuilt rpm,

....

....

....

sudo /opt/freescale/ltib/usr/bin/rpm --root /home/cyabc/ltib/rootfs --dbpath /var/lib/rpm -e --allmatches --nodeps --define '_tmppath /tmp/ltib' base_libs 2>/dev/null
sudo /opt/freescale/ltib/usr/bin/rpm --root /home/cyabc/ltib/rootfs --dbpath /var/lib/rpm --prefix / --ignorearch -ivh --force --excludedocs --define '_tmppath /tmp/ltib' /home/cyabc/ltib/rpm/RPMS/arm/base_libs-1.2-1.arm.rpm
error: failed dependencies:
ld-linux.so.3(GLIBC_2.4)   is needed by base_libs-1.2-1


f_buildrpms() returned an error, exiting
traceback:
main:572


Started: Fri Jun 14 20:57:47 2013
Ended:   Fri Jun 14 21:17:12 2013
Elapsed: 1165 seconds


Build Failed

 

 

 

 

I have attched the error log in attachment file. Could anyone can help to resolve this problem


Original Attachment has been moved to: ltib_build_logt.txt.zip

Outcomes