AnsweredAssumed Answered

Urgent! How to write boot stream/rootfs into eMMC(SD1) on i.MX28?

Question asked by Tsung-Fang Tu on May 18, 2013

Hi All,

 

      Our board is designed based on both i.MX28 EVK and HEG (Adeneo Embedded Home Energy Gateway), the original SD1 on EVK board is replaced by a 4GB eMMC. The customer request the board should be boot by eMMC while the SD0 is only prepared for external storage.However, the boot stream/rootfs writing into eMMC(SD1) through MFGTools is always failed while it works fine if we insert a SD card in SD0 slot.

 

      Have reviewed all document but no instruction for writing SD1, although we do notice below note on page 3-10, i.MX28 EVK Linux User's Guide :

 

     "The i.MX28 EVK board needs hardware rework for booting from SD1 (see EVK Hardware user Guide for details)"

 

       Our hardware team has followed and designed the board based on the instruction on page 2-11 of EVK Hardware user Guide and the i.MX28 EVK board can be boot by SD1 after hardware rework accordingly.

 

        Now the urgent issues is how to write boot stream/rootfs into eMMC, we have tried to use MFGTools (rel-1.6.2.0322) on both of our board(eMMC) and EVK board(SD1), but both return same error message on MFGTools:

 

        Update error: 0xffffffea (-22) -

 

         The eMMC can be recognized/partition/format if we boot the board by SD0, therefore we also tried to manually write boot stream/rootfs into eMMC after booting by SD0, but rootfs never fully copied and boot by eMMC is still failed (of course, we have set the switch to 1010).

 

         Please ref. to attachment for console log(by Mfgtools) and our manual script. Any comment/suggestion is highly appreciate!

 

BR,

 

TF

 

Original Attachment has been moved to: writeEMMC.sh

Original Attachment has been moved to: 20130518EVKSD1.log.zip

Outcomes