AnsweredAssumed Answered

Unable to find OpenSDA serial ports

Question asked by easyfarmautomat on Jan 18, 2013
Latest reply on Jan 18, 2013 by easyfarmautomat

I have three FRDM-KL25Z boards. I follow the instructions and can bring up the boatloader drive.

 

I can download the DEBUG-APP_Pemicro_v102.SDA program, and (after disconnecting and reconnecting the USB cable) I get the Jungo/PEMicro OpenSDA Debug Driver and the Ports/OpenSDA - CDC Serial Port devices coming up in the Device Manager. In the Devices and Printers window I see, under a 'Unspecfied' tab, an OpenSDA Hardware device.  Also the green light stays on on the board.

 

I can download the MSD-FRDM-KL25Z_Pemicro_v105.SDA program and (after reconnecting) I get the FRDM-KL25Z drive appearing, and also i get the Ports/OpenSDA-CDC Serial Port in the device manager. I can also drag and drop a program (ie Blinky) into the drive and it will run. In the Devices and Printers window I see a PEMicro/Freescale-cdc Serial Port under the Devices tab. Also the green light on the board remains on.

 

However when I copy the CMSIS-DAP_OpenSDA.S19 program into the bootloader the only thing I see in the device manager list is a new entry for a Human Interface Devices, which has two entries under it, 'HID-compliant device' and a 'USG Input Device'. There are no serial ports shown. In the Devices and Printers window I see, under the Unspecified tab, an OpenSDA CMSIS-DAP device. The green light on the board does not remain on. And I cannot access the board to download a program from the CooCox IDE (It says  CMSIS-DAP not found, make sure adapter is connected).

 

I have tried this on two separate FRDM-KL25Z boards, and on neither does the CMSIS-DAP program produce a serial port. The computer I am using is a Windows 7 machine. I have also tried loading the CMSIS-DAP program to the board using my Windows 7 laptop, with the same results (no serial port). I have also tried loading the CMSIS-DAP program using an old Windows XP machine, still no serial port found, but in both cases two extra entries appeared the generic Human Interface Devices tab in the device manager.

 

I have also tried un-installing and re-installing the drivers from PEMicro (many times), to no avail.

 

If someone could please tell me what I am doing wrong I will appreciate it.

 

Thankyou,

David.

Outcomes