AnsweredAssumed Answered

Installing MQX on custom board

Question asked by syedr on Nov 18, 2012
Latest reply on Apr 16, 2013 by chiasyan

Hello,

 

I am currently working with the TWR-K60N512 dev kit ( with a PK60N512VMD100 chip) and MQX 3.8 and have a custom board with the MK60DN512LVQ10 chip. My code works and flashes without any problems on the dev kit.But whenever I try to debug the code on my custom board with the MQX I run into problems. First off my code is able to flash on the custom board, but the pointer immediately jumps to the dispatch.s file in the _int_kernel_isr function, it stops right at the "cpsid.n i" instruction. When I press the debug button again the pointer moves cortext_boot.s file at this assembly instruction:       

 

ldr r0, =0xe000e180     ; NVIC_ICER0 - Interrupt Clear-Enable Registers

 

If I keep pressing the resume button on my debugger the pointer keeps moving back and forth between these two files.

 

I have tried changing the MQX settings in my user_config.h file for MQX_ROM_VECTORS from true to false. When I have it set to true the above problem is encountered and when I set it to false the pointer starts off in the vectors.c file at the following while loop:

 

static void __boot_exception(void) {

        while(1);

    }

 

Also at random times during debug, the code starts off at the mqx_main.c file but ends up in the cortex_boot.s file.

 

I have an idea that the problem is related to some interrupt but cannot point out how to debug this problem since I can't seem to bypass this issue during debugging. Also on a side-note  I have compiled non MQX based code and flashed it to my custom board, and that worked without any problems and I was able to debug and step through my code.

 

Any help on this would be greatly appreciated.

 

Thanks

 

 

 

Attachments

Outcomes