Florentino Florentino

[Troubles]Ltib compilation with the profile FSL gnome release packages

Discussion created by Florentino Florentino on Aug 20, 2012

Hi everybody,


I’m trying to compile a Linux distribution for an i.mx6 board with Gnome but I have some troubles!
Firstly, you need to know that I work with: L3.0.15_12.04.01_ER_source.tar.gz
And my compilation with the minimal profile was a success (without X).
Now I want to try my build a HMI, but my compilation failed when I arrived on the Gnome-vst package, I have this error message (the commands are in bold, the results italic )


./ltib --preconfig config/platform/imx/imx6q.cf --profile config/platform/imx/release_gnome.profile
/opt/freescale/usr/local/gcc-4.6.2-glibc-2.13-linaro-multilib-2011.12/fsl-linaro-toolchain/bin/../lib/gcc/arm-fsl-linux-gnueabi/4.6.2/../../../../arm-fsl-linux-gnueabi/bin/ld: cannot find -lgssapi_krb5
/opt/freescale/usr/local/gcc-4.6.2-glibc-2.13-linaro-multilib-2011.12/fsl-linaro-toolchain/bin/../lib/gcc/arm-fsl-linux-gnueabi/4.6.2/../../../../arm-fsl-linux-gnueabi/bin/ld: cannot find -lkrb5
/opt/freescale/usr/local/gcc-4.6.2-glibc-2.13-linaro-multilib-2011.12/fsl-linaro-toolchain/bin/../lib/gcc/arm-fsl-linux-gnueabi/4.6.2/../../../../arm-fsl-linux-gnueabi/bin/ld: cannot find -lk5crypto
collect2: ld returned 1 exit status
make[2]: *** [libftp.la] Error 1
make[2]: Leaving directory `/home/psa/Ltib/ltib/rpm/BUILD/gnome-vfs-2.24.1/modules'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/psa/Ltib/ltib/rpm/BUILD/gnome-vfs-2.24.1'
make: *** [all] Error 2
error: Bad exit status from /home/psa/Ltib/ltib/tmp/rpm-tmp.46078 (%build)

RPM build errors:
    Bad exit status from /home/psa/Ltib/ltib/tmp/rpm-tmp.46078 (%build)
Build time for gnome-vfs: 23 seconds
Failed building gnome-vfs

So I tried to compile the Kerberos package alone. There was no krb5-1.3.4.tar.gz in my sources, but there were the patch krb5-fix-build-error.patch and the spec file kbr5.spec.


You can watch two files in attached files.


The kbr5.spec do reference at two others patches:
Patch1          : kbr5-1.3.4-fix-EAI_NODATA-undefined-check.patch
Patch2          : kbr5-1.3.4-fix-conflicting-types-for-getline.patch


I could download kb5.1.3.tar.gz. But, I could'nt find these patches on web.
I have tried to compile kb5-1.3.4.tar.gz without the two patches (I have commented the lines ,where there were references  to thes patches) ,and I have thes messages..:

./ltib -m prep krb5.spec -p krb5
+ echo Patch #0 (krb5-fix-build-error.patch):
Patch #0 (krb5-fix-build-error.patch):
+ patch -p1 -s
+ exit 0
Build time for krb5: 1 seconds


And :


./ltib -m scbuild krb5.spec -p krb5
cd krb5-1.3.4
+ ac_cv_func_regcomp=yes ac_cv_file__etc_environment=yes ac_cv_file__etc_TIMEZONE=yes ac_cv_func_res_search=yes
/home/psa/Ltib/ltib/tmp/rpm-tmp.41503: 1: ac_cv_func_regcomp=yes ac_cv_file__etc_environment=yes ac_cv_file__etc_TIMEZONE=yes ac_cv_func_res_search=yes: not found
error: Bad exit status from /home/psa/Ltib/ltib/tmp/rpm-tmp.41503 (%build)
RPM build errors:
    Bad exit status from /home/psa/Ltib/ltib/tmp/rpm-tmp.41503 (%build)
Build time for krb5: 0 seconds
Failed building krb5
f_scbuild() returned an error, exiting


So, maybe somebody have the same problem or could help me.
I have hope in the i.MX community :)
Thanks
Best regards


Florent

Original Attachment has been moved to: 30-krb5fixbuilderror.patch

Original Attachment has been moved to: 29-krb5.spec

Outcomes