RT1050 - MCUXpresso support

cancel
Showing results for 
Search instead for 
Did you mean: 

RT1050 - MCUXpresso support

697 Views
Contributor IV

Hello, I am trying to get some clarification on RT1050 Support in MCUXpresso.  According to the RT1050 product page and fact sheet, RT1050 is supposed to be supported by the MCUXpresso IDE:

Product Page:

front_page.png

Fact Sheet:

fact_sheet.png

However, when you attempt to create an SDK for the RT1050 MCUXpresso is not available in the tool chain drop-down and is not listed in the supported environments:

Drop-down (does not change with OS):

all_toolchains.png

Supported IDEs:

gcc_arm_embed.png

Any attempt to import an SDK into MCUExpresso results in the following error:

eclipse.buildId=unknown
java.version=1.8.0_111
java.vendor=Oracle Corporation
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_CA
Command-line arguments:  -data file:/home/xxxx/Documents/MCUXpresso_10.0.2_411/workspace/ -os linux -ws gtk -arch x86_64

com.nxp.mcuxpresso.core.datamodels
Error
Mon Nov 06 13:48:59 PST 2017
The SDK 'SDK_2.x_EVK-MIMXRT1050' does not contain any MCUXpresso IDE compatible toolchain.

     at com.nxp.mcuxpresso.core.datamodels.providers.SDKManifestProvider.addToMap(SDKManifestProvider.java:530)
     at com.nxp.mcuxpresso.core.datamodels.providers.SDKManifestProvider.access$0(SDKManifestProvider.java:519)
     at com.nxp.mcuxpresso.core.datamodels.providers.SDKManifestProvider$1.preVisitDirectory(SDKManifestProvider.java:374)
     at com.nxp.mcuxpresso.core.datamodels.providers.SDKManifestProvider$1.preVisitDirectory(SDKManifestProvider.java:1)
     at java.nio.file.Files.walkFileTree(Files.java:2677)
     at java.nio.file.Files.walkFileTree(Files.java:2742)
     at com.nxp.mcuxpresso.core.datamodels.providers.SDKManifestProvider.refresh(SDKManifestProvider.java:366)
     at com.nxp.mcuxpresso.core.datamodels.ui.jobs.SDKImportJob.doRefresh(SDKImportJob.java:324)
     at com.nxp.mcuxpresso.core.datamodels.ui.jobs.SDKImportJob.run(SDKImportJob.java:94)
     at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)

I have tried other RT105x SDK variants with the same results. 

If the RT1050 is indeed supported by the MCUExpresso IDE then what exactly is the procedure to build and import the SDK?  If it is not supported then please remove the misleading statements from the product literature as they lead to the waste of valuable time and energy. 

I have reviewed the guides and forums posts (like this one) so no RTFM responses please unless they are specific to this issue.

Labels (1)
Tags (4)
0 Kudos
1 Reply

81 Views
NXP Employee
NXP Employee

HI Ryan,

please see when will IDE support IMXRT105X? Seems that IAR is required for SDK_2.3.0_EVK-MIMXRT1050 and new EVM... 


Regards,
Carlos

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos