Not debugging to flash

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Not debugging to flash

Jump to solution
604 Views
Charindu_Abeysekara
Contributor II

"Encountering 'Error: Could not load file' while using CMSIS-DAP Debugger on MIMXRT1170-EVK board with uVision 5 software. Attempting the 'hello world' example project from the pack installer. Any suggestions?"

Error: Could not load file 'ram_0x1400_debug\hello_world_demo_cm4.out'. Debugger aborted !


i.MX-RT1170 

0 Kudos
1 Solution
185 Views
HangZhang
NXP Employee
NXP Employee

This issue may be due to ARM:: CMSIS 6.0.0 package being incompatible with your project or system environment, or an error occurring during the installation process. We suggest you try the following methods:

Ensure that your system environment meets the installation requirements of ARM: CMSIS 6.0.0.
Check your project configuration to ensure there are no errors or conflicts.
Try reinstalling the ARM:: CMSIS 6.0.0 package to ensure that there are no error messages during the installation process.
If the problem persists, you can try using a different version of the ARM:: CMSIS package.

Hope this will help you.

BR

Hang

View solution in original post

0 Kudos
8 Replies
503 Views
Charindu_Abeysekara
Contributor II

When the ARM::CMSIS 6.0.0 removed only the example codes and other codes builts otherwise the above mentioned error is occured .after removed the above pack version it was built successfully.any one know whys that ?

0 Kudos
486 Views
HangZhang
NXP Employee
NXP Employee

Hi @Charindu_Abeysekara 

I'm sorry, I didn't understand the meaning of this sentence 'the ARM::CMSIS 6.0.0 removed only the example codes and other codes builts'.

Can you give me more details?

BR

Hang

0 Kudos
220 Views
Charindu_Abeysekara
Contributor II
in the pack installer the recomanded pack called ARM::CMSIS 6.0.0 removed only the buil will happen do you know why its happening like that ?
0 Kudos
186 Views
HangZhang
NXP Employee
NXP Employee

This issue may be due to ARM:: CMSIS 6.0.0 package being incompatible with your project or system environment, or an error occurring during the installation process. We suggest you try the following methods:

Ensure that your system environment meets the installation requirements of ARM: CMSIS 6.0.0.
Check your project configuration to ensure there are no errors or conflicts.
Try reinstalling the ARM:: CMSIS 6.0.0 package to ensure that there are no error messages during the installation process.
If the problem persists, you can try using a different version of the ARM:: CMSIS package.

Hope this will help you.

BR

Hang

0 Kudos
180 Views
Charindu_Abeysekara
Contributor II
Thank for your Time.it worked with different version of arm version.i ll check the system environment again.
0 Kudos
523 Views
Charindu_Abeysekara
Contributor II

it occurs 5 errors occurs undeclared identifier. 

0 Kudos
516 Views
HangZhang
NXP Employee
NXP Employee

Hi @Charindu_Abeysekara 

According to the error message, you may be lack of core_cm4.h. Please check it.

Or you can reinstall the chip pack.

 

HangZhang_0-1713259027148.png

Hope this will help you.

BR

Hang

0 Kudos
584 Views
HangZhang
NXP Employee
NXP Employee

Hi @Charindu_Abeysekara 

I can run hello world' example using CMSIS-DAP Debugger successfully on MIMXRT1170-EVK board.

So please check if JP5 is open on board. And please try reinserting the serial cable.

Hope this will help you.

BR

Hang

0 Kudos