imx28 with linux-3.0.35

cancel
Showing results for 
Search instead for 
Did you mean: 

imx28 with linux-3.0.35

Jump to solution
366 Views
___myir
Contributor II

Dear All,

The linux-2.6.35 is older version, so I would like to turn to linux-3.0.35, but it is not smooth.

Chosen Linux 3.0.35-imx from the menu of "./ltib -m config", then type ./ltib for building. I got the error message:

Processing: kernel-3.0.35

===========================

Build path taken because: build key set, no prebuilt rpm,

Testing network connectivity

OK GPP:

Try linux-3.0.35.tar.bz2.md5 from the GPP

http://bitshrine.org/gpp/linux-3.0.35.tar.bz2.md5:

15:37:40 ERROR 404: Not Found.

Try linux-3.0.35.tar.bz2 from the GPP

http://bitshrine.org/gpp/linux-3.0.35.tar.bz2:

15:37:40 ERROR 404: Not Found.

Can't get: linux-3.0.35.tar.bz2 at ./ltib line 802.

f_buildrpms() returned an error, exiting

traceback:

main:572

Started: Wed Dec  9 15:37:33 2015

Ended:   Wed Dec  9 15:37:40 2015

Elapsed: 7 seconds

These packages failed to build:

kernel-3.0.35

Build Failed

Exiting on error or interrupt

Ok, I thought the linux-3.0.35.tar.bz2 could not be downloaded. so I downloaded from:

linux-3.0.35.tar.bz2 [73.29 MiB] - MD5: 70bda6ecf3c498b23d2ced776479a8c3 - Fileinformation

and placed to /opt/freescale/pkgs directory, create the linux-3.0.35.tar.bz2.md5 manually, then run ./ltib again, got another error:

Processing: kernel-3.0.35

===========================

Build path taken because: build key set, no prebuilt rpm,

Testing network connectivity

OK GPP:

Try linux-3.0.35-imx_10.12.01.bz2.md5 from the GPP

http://bitshrine.org/gpp/linux-3.0.35-imx_10.12.01.bz2.md5:

17:00:32 ERROR 404: Not Found.

Try linux-3.0.35-imx_10.12.01.bz2 from the GPP

http://bitshrine.org/gpp/linux-3.0.35-imx_10.12.01.bz2:

17:00:33 ERROR 404: Not Found.

Can't get: linux-3.0.35-imx_10.12.01.bz2 at ./ltib line 802.

f_buildrpms() returned an error, exiting

traceback:

main:572

Started: Wed Dec  9 17:00:29 2015

Ended:   Wed Dec  9 17:00:33 2015

Elapsed: 4 seconds

These packages failed to build:

kernel-3.0.35

Build Failed

Exiting on error or interrupt

Hmmm...... now, the linux-3.0.35-imx_10.12.01.bz2 could not be download, and I could not find this file by google.

Could anyone provide some helps? Thanks in advance!

Best Regards,

Kinly,

Labels (1)
0 Kudos
1 Solution
36 Views
fabio_estevam
NXP Employee
NXP Employee

3.0.35 does not support mx28.

If you plan to update your kernel, then you could use something more recent, such as 4.3 kernel.

Also, LTIB is not supported anymore, so you could try Yocto instead.

Regards,

Fabio Estevam

View solution in original post

0 Kudos
2 Replies
37 Views
fabio_estevam
NXP Employee
NXP Employee

3.0.35 does not support mx28.

If you plan to update your kernel, then you could use something more recent, such as 4.3 kernel.

Also, LTIB is not supported anymore, so you could try Yocto instead.

Regards,

Fabio Estevam

View solution in original post

0 Kudos
36 Views
___myir
Contributor II

Hi Fabio,

Thanks for your reply. I got it.

I will try the Yocto.

Best Regards,

Kinly

0 Kudos