iMX51 EVK u-boot build question

cancel
Showing results for 
Search instead for 
Did you mean: 

iMX51 EVK u-boot build question

1,023 Views
brianlin
Contributor II

Hi all,

I download [imx-android-r10.4_bundle_BSP.tar.gz] from Freescale website and follow its user guide [i.MX Android R10.4 User Guide].

I am trying to build a u-boot image by myself. So I follow all the steps of source code download like below.

$ cd myandroid/bootable/bootloader
$ git clone git://git.denx.de/u-boot.git uboot-imx


After [uboot-imx] folder download finish. And finish apply R10.4 release patch.

Then I try to follow below steps and caused an Error message below. I found there is no string [mx51_bbg_android_config] in makefile. and related mx51_bbg_android file such as mx51_bbg_android.h in [uboot-imx] folder. Which steps I missed? Please help me. Thank you.


$ cd ~/myandroid/bootable/bootloader/uboot-imx   
$ export ARCH=arm
$ export CROSS_COMPILE=~/myandroid/prebuilt/linux-x86/toolchain/arm-eabi-4.3.1/bin/arm-eabi-
Command to build for i.MX51 BBG board is:
$ make distclean
$ make mx51_bbg_android_config
$ make

Error message:

make: *** No rule to make target `mx51_bbg_android_config'.  Stop.


Labels (2)
10 Replies

166 Views
OtavioSalvador
Senior Contributor II

The DENX U-Boot is the mainline U-Boot and the MX50EVK board target is different.

Please use:

make mx51evk_config

166 Views
brianlin
Contributor II

Many Thanks! It works.

Another question, what name I should put for Kernel build. Seems below name is incorrect.

make imx5_android_defconfig

0 Kudos

166 Views
brianlin
Contributor II

Sorry, I found out the correct name.

$ make mx51_defconfig


Now I am checking how to build Android image with correct product name.


$lunch imx51_bbg-user

Error message:

build/core/product_config.mk:203: *** No matches for product "imx51_bbg".  Stop.

** Don't have a product spec for: 'imx51_bbg'

** Do you have the right repo manifest?


0 Kudos

166 Views
OtavioSalvador
Senior Contributor II

I am not an Android guy so I won't be able to help here.

0 Kudos

166 Views
brianlin
Contributor II

Thank you Otavio. But here I face a boot problem. After I build u-boot.bin and uImage. I flash in my SD card and try to boot MX51 EVK board. It cannot boot-up. I don't know what's wrong. Can you give me some advice?

Here is my SD card partition status:

Device BootStart  EndBlocks  Id  System
/dev/sdb1    19532139490646964766+  83  Linux
/dev/sdb2  1394906514925664488300  83  Linux
/dev/sdb3  14925665159256645000005  Extended
/dev/sdb4  159256651601945546895+  83  Linux
/dev/sdb5  1492771315806653439470+  83  Linux
/dev/sdb6  158087021592566458481+  83  Linux

Flash u-boot-no-padding.bin command:

$ sudo dd if=u-boot-no-padding.bin of=/dev/sdb bs=1K seek=1; sync

Result:

301+1 records in

301+1 records out

308864 bytes (309 kB) copied, 0.103723 s, 3.0 MB/s

Flash uImage command:

$ sudo dd if=uImage of=/dev/sdb bs=1M seek=1; sync

Result:
1+1 records in
1+1 records out
1897828 bytes (1.9 MB) copied, 0.00358143 s, 530 MB/s

0 Kudos

166 Views
OtavioSalvador
Senior Contributor II

What is the log, in serial console?

0 Kudos

166 Views
brianlin
Contributor II

Hi,

Serial console showing like this when I press power bottom up. (when my finger leave the bottom). Seems no boot start. Is it my partition wrong? or something else? Thanks.

B�2&ƌ |��������


0 Kudos

166 Views
OtavioSalvador
Senior Contributor II

It could well be it; I'd test the Yocto built image as I know it works.

0 Kudos

166 Views
brianlin
Contributor II

Hi, I follow below link. It works.

i.MX51 EVK U-boot

166 Views
LeonardoSandova
Specialist I

Double check the u-boot repo. I don’t have the documentation at hand, but it can be this git://git.freescale.com/imx/uboot-imx.git

0 Kudos