Yocto SDCard image not booting on iMX6QSabreLite

Showing results for 
Show  only  | Search instead for 
Did you mean: 

Yocto SDCard image not booting on iMX6QSabreLite

Contributor II


I'm using Ubuntu 18.04.2 LTS (having recently upgraded from Ubuntu 14.04 LTS) and set my environment up like this:

(Install pre-requisites)

> mkdir fsl

> cd fsl

> repo init -u https://github.com/Freescale/fsl-community-bsp-platform -b pyro

> repo sync

> mkdir build

> MACHINE=nitrogen6x DISTRO=poky source setup-environment build

> bitbake core-image-minimal

Build completed with no errors and 3 warnings about a missing item but it tried a mirror site and found it there.

> cd build/tmp/deploy/images/nitrogen6x

<insert SDCard - appears as /dev/sdb>

> gunzip -c core-image-minimal-nitrogen6x-20190626151810.rootfs.sdcard.gz | sudo dd of=/dev/sdb bs=4M

0+1127 records in

0+1127 records out

37748736 bytes (38MB, 36MiB) copied, 0.223933 s, 169MB/s

> sync

Remove SDCard and insert it into the target and power on. In the terminal window, I get:

SATA device 1: unknown device
** Bad device sata 1 **
** Bad device sata 1 **
MMC: no card present
mmc0(part 0) is current device
MMC: no card present
** Bad device mmc 0 **
MMC: no card present
** Bad device mmc 0 **
mmc1 is current device
reading /6x_bootscript
4202 bytes read
## Executing script at 10008000
!!!! Error: Your u-boot is outdated. Please upgrade.
Failed to mount ext2 filesystem...
** Unrecognized filesystem type **

6x_bootscript not found

serial console at 115200, 8N1

details at http://boundarydevices.com/6q_bootscript
U-Boot >

My questions/comments are:

1) I previously used Ubuntu 14.04 with Yocto version Dylan and that produced an SDCard which booted perfectly for many years on my target. We've recently updated to Ubuntu 18.04 and Dylan no longer builds. In fact, I tried all versions of Yocto incrementally form Dylan and Pyro was the first one that would build on Ubuntu 18.04.

2) The SDCard image looks a little small - I was expecting around 3G for the entire image.

3) What have I done wrong? 

4) Does Yocto no longer build the latest version of uBoot?


Labels (2)
0 Kudos
2 Replies

Contributor II


I've figured it out. I updated the uBoot image:

Downloaded a new uBoot (2017-070 from here: https://boundarydevices.com/u-boot-v2017-07/

Copied it to the FAT32 partition on the SDCard. Boot the target and at the uBoot prompt:

mmc dev 1

fatload mmc 1:1 12000000 u-boot.nitrogen6q

            (Note image size)

sf probe

sf erase 0 0xc2000

sf write 0x12000000 0x400 <filesize> (from above in hex)


After the reset the Linux image that I built earlier boots.

I'll put this here in case someone else has this problem in future.

0 Kudos

NXP TechSupport
NXP TechSupport


0 Kudos