Integrate SD card to evkmimxrt1060_tensorflow_lite_kws

cancel
Showing results for 
Search instead for 
Did you mean: 

Integrate SD card to evkmimxrt1060_tensorflow_lite_kws

Jump to solution
205 Views
nahan_trogn
Contributor III

Hi NXP,

I want to integrate SD card to evkmimxrt1060_tensorflow_lite_kws, but not success.The console stuck in "Make file system......The time may be long if the card capacity is big."

When debug, I see that Program is hanging in disk_initialize()

I copied all file in fatfs,sdmmc,board,driver,component,... from example SDcard project to my kws project, and define SD_ENABLED in pre-processor.

This attached link is my project (27MB)https://drive.google.com/file/d/1YOzNcXlGXQGUtHLPs1uZehqtpYvVcQug/view?usp=sharing 

Thanks in advance.

 

0 Kudos
1 Solution
134 Views
Alexis_A
NXP TechSupport
NXP TechSupport

Hello @nahan_trogn,

Modifying the memory map like the following one I was able to debug your proyect:

Alexis_A_0-1621472087356.png

It looks like using the buffers for the SD outside the internal memory cause some problems.

Best Regards,

Alexis Andalon

 

 

View solution in original post

0 Kudos
5 Replies
180 Views
Alexis_A
NXP TechSupport
NXP TechSupport

Hello @nahan_trogn,

Did you try the SD project before to check that the SD is correctly recognized?

Best Regards,

Alexis Andalon

0 Kudos
175 Views
nahan_trogn
Contributor III

Yes, I had run evkmimxrt1060_sai_peripheral, evkmimxrt1060_sai, evkmimxrt1060_sdcard_fatfs. Everything is ok.

0 Kudos
159 Views
Alexis_A
NXP TechSupport
NXP TechSupport

Hello @nahan_trogn,

Unfortunately, I can't download the project from the link attached. Could you try to attach it to the post?

Best Regards,

Alexis Andalon

0 Kudos
155 Views
nahan_trogn
Contributor III

Hi,

I've re-uploaded my project to MEGA

https://mega.nz/file/lPIylRiT#_I5_EaqcBjvJzILgR67aAUUFuKD6UnNuAaYStE2mPyA 

Since project's size is more than 25MB so I can't attach it.

Thanks.

0 Kudos
135 Views
Alexis_A
NXP TechSupport
NXP TechSupport

Hello @nahan_trogn,

Modifying the memory map like the following one I was able to debug your proyect:

Alexis_A_0-1621472087356.png

It looks like using the buffers for the SD outside the internal memory cause some problems.

Best Regards,

Alexis Andalon

 

 

View solution in original post

0 Kudos