I can't compile with Yocto toolchain

cancel
Showing results for 
Search instead for 
Did you mean: 

I can't compile with Yocto toolchain

2,363 Views
aaronpadilla
Contributor II

Issue with Yocto toolchain

I have compiled the yocto toolchain using :

To create the folder build for bitbake or prepare the environnement:

MACHINE=imx6sxsabresd source fsl-setup-release.sh -b build

Build the toolchain image

$ bitbake meta-toolchain

Browse to

/build/tmp/deploy/sdk

Build the toolchain:

./fsl-imx-x11-glibc…sh   or source fsl-imx-x11-glibc…sh    <—pas sure

Setting environment variables

/opt/fsl-imx-x11/3.14.52-1.1.0

$ source environment-setup-cortexa9hf…..

Compiling hello test

$CC hello.c

and it works but I would like to compile libjpeg so I tried

./configure --host=arm-linux $CC

aaron@aaron-X550CA:~/jpeg-9b$ ./configure --host=arm-linux $CC

configure: WARNING: you should use --build, --host, --target

configure: error: unrecognized option: `-march=armv7-a'

Try `./configure --help' for more information

aaron@aaron-X550CA:~/jpeg-9b$

CC is :

arm-poky-linux-gnueabi-gcc -march=armv7-a -mfloat-abi=hard -mfpu=neon -mtune=cortex-a9 --sysroot=/opt/fsl-imx-x11/3.14.52-1.1.0/sysroots/cortexa9hf-vfp-neon-poky-linux-gnueabi

I then tried

./configure --host=arm-linux CC=arm-poky-linux-gnueabi-gcc

aaron@aaron-X550CA:~/jpeg-9b$ ./configure --host arm-linux  CC=arm-poky-linux-gnueabi-gcc

configure: loading site script /opt/fsl-imx-x11/3.14.52-1.1.0/site-config-cortexa9hf-vfp-neon-poky-linux-gnueabi

checking build system type... x86_64-unknown-linux-gnu

checking host system type... arm-unknown-linux-gnu

checking target system type... arm-unknown-linux-gnu

checking for a BSD-compatible install... /usr/bin/install -c

checking whether build environment is sane... yes

checking for arm-linux-strip... arm-poky-linux-gnueabi-strip

checking for a thread-safe mkdir -p... /bin/mkdir -p

checking for gawk... gawk

checking whether make sets $(MAKE)... yes

checking whether make supports nested variables... yes

checking whether make supports nested variables... (cached) yes

checking whether to enable maintainer-specific portions of Makefiles... no

checking for arm-linux-gcc... arm-poky-linux-gnueabi-gcc

checking whether the C compiler works... no

configure: error: in `/home/aaron/jpeg-9b':

configure: error: C compiler cannot create executables

See `config.log' for more details

aaron@aaron-X550CA:~/jpeg-9b$

Could you advise??

1 Reply

499 Views
gusarambula
NXP TechSupport
NXP TechSupport

Hello Aaron Padilla,

Are you still having issues compiling? I found some suggestions on building from the multimedia codecs sources on the following thread. It's not specific for your configuration but maybe it could help.

LTIB building err for imx6q_sabresd