DirectFB support for L3.14.52_1.1.0-ga BSP

cancel
Showing results for 
Search instead for 
Did you mean: 

DirectFB support for L3.14.52_1.1.0-ga BSP

Jump to solution
767 Views
torus1000
Contributor V

Hi,

I was surprised this BSP( L3.14.52 ) didn't support DirectFB anymore but I prefer this backend.

So I tried to build it then following ERROR occurred.

$ cd fsl-release-bsp

$ repo init -u git://git.freescale.com/imx/fsl-arm-yocto-bsp.git -b imx-3.14.52-1.1.0_ga

$ repo sync

$ source setup-environment

#### command #1

$ DISTRO=fsl-imx-dfb MACHINE=imx6qpsabreauto source fsl-setup-release.sh -b build-dfb

#### command #2

#### $ MACHINE=imx6qpsabresd source fsl-setup-release.sh -b build-dfb -e dfb

#### error log

$ bitbake fsl-image-qt5

ERROR:  OE-core's config sanity checker detected a potential misconfiguration.

    Either fix the cause of this error or at your own risk disable the checker (see sanity.conf).

    Following is the list of potential problems / advisories:

    DISTRO 'fsl-imx-dfb' not found. Please set a valid DISTRO in your local.conf

Summary: There was 1 ERROR message shown, returning a non-zero exit code.

Does anyone already tried to build DirectFB?

How can I get fsl-imx-dfb conf?

Can anyone help me? Please let me know how to avoid this error.

Thanks.

Tags (2)
0 Kudos
1 Solution
145 Views
igorpadykov
NXP TechSupport
NXP TechSupport

HI torus1000

please refer to attached part of Freescale_Yocto_Project_User's_Guide.pdf

1.jpg

that means that it is necessary to apply to third party or contact

NXP Professional Services for developing this backend

http://www.nxp.com/pages/freescale-professional-services:PROFESSIONAL-SERVICES

Best regards

igor

-----------------------------------------------------------------------------------------------------------------------

Note: If this post answers your question, please click the Correct Answer button. Thank you!

-----------------------------------------------------------------------------------------------------------------------

View solution in original post

0 Kudos
3 Replies
145 Views
prasanthr
Contributor II

bitbake fsl-image-qt5
NOTE: Your conf/bblayers.conf has been automatically updated.
ERROR: OE-core's config sanity checker detected a potential misconfiguration.
Either fix the cause of this error or at your own risk disable the checker (see sanity.conf).
Following is the list of potential problems / advisories:

DISTRO 'fsl-imx-fb' not found. Please set a valid DISTRO in your local.conf

is also not working is there any issue with the distro or is there any other alternative for it??

0 Kudos
146 Views
igorpadykov
NXP TechSupport
NXP TechSupport

HI torus1000

please refer to attached part of Freescale_Yocto_Project_User's_Guide.pdf

1.jpg

that means that it is necessary to apply to third party or contact

NXP Professional Services for developing this backend

http://www.nxp.com/pages/freescale-professional-services:PROFESSIONAL-SERVICES

Best regards

igor

-----------------------------------------------------------------------------------------------------------------------

Note: If this post answers your question, please click the Correct Answer button. Thank you!

-----------------------------------------------------------------------------------------------------------------------

View solution in original post

0 Kudos
145 Views
torus1000
Contributor V

Dear Igor

Thank you for your advice. It seems not so easy.

Now I understand the ERROR suggested missing conf file. So I made <yocto>/source/meta-bsp-release/imx/meta-sdk/conf/distro/fsl-imx-dfb.conf then error was cleared.

BR

0 Kudos