ZPS_EVENT_NWK_LEAVE_INDICATION event does not occur when the End Device leave.

cancel
Showing results for 
Search instead for 
Did you mean: 

ZPS_EVENT_NWK_LEAVE_INDICATION event does not occur when the End Device leave.

Jump to solution
1,184 Views
seunghokims
Contributor III

Coordinator changed from Zigbee 1.2(JN-AN-1223) to Zigbee 3.0(JN-AN-1216).

ZigBee 3.0 does not receive leave event of the end device.

Environment When no event occurs (ZPS_EVENT_NWK_LEAVE_INDICATION )

- zigbee 3.0 : JN-AN-1216-Zigbee-3-0-IoT-ControlBridge-v1011
- Coordinator : JN-AN-1216
- End Device : Ember Zigbee

Ember&AN1216_Leave.png

The event does not occur in the following source code.
Source Code.png

 Environment when event occurs

TEST #1 :

- zigbee 3.0 : JN-AN-1216-Zigbee-3-0-IoT-ControlBridge-v1011
- Coordinator : JN-AN-1216

-  Change End Device to Jn5169

Jn5169&AN1216_Leave-Ok.png

 Environment when event occurs

TEST #2 :

- zibee 1.2 : JN-AN-1223-ZigBee-IoT-Gateway-v1014
- Change Coordinator to Zigbee 1.2

- End Device : Ember Zigbee

ember&AN1223_Leave-Ok.png

Labels (1)
0 Kudos
1 Solution
918 Views
Garabo
NXP TechSupport
NXP TechSupport

Hi Kim,
The inconvenience we see here is that your Ember device seems to be not fully compatible with V3. You need to confirm to us that it is able to connect with V3. Our device is 100% compatible with V3 as our certificate shows (https://zigbeealliance.org/zigbee_products/nxp-jn516x-zbpro-r22/). From this point, there is nothing else we can do to help to debug your Ember device. Please report this issue with the manufacturer.

Best Regards,

Garabo

View solution in original post

0 Kudos
11 Replies
918 Views
seunghokims
Contributor III

Hi,Sebastian

 

Thank you for your reply.

Yes, there is no problem with Jn5169.

And with the Zigbee Pro (AN-1223), both Jn5169 and Ember are no problem.

Problems occur in Zigbee 3.0 (An-1216 & An-1217).

When guessing, It doesn't seem to be received when the destination Address is 0x0000.

log is attached.

- An1223 succeeds in receiving.

- The log does not show any difference.

- There is no event received by App_vGenCallback in An-1216.

Best regards,

Kim

0 Kudos
918 Views
Sebastian_Del_Rio
NXP TechSupport
NXP TechSupport

Hi Kim,

 

I tried replicating your issue, but the event is being generated accordingly.

 

I noticed a difference in the sniffer logs you provided and the one in my tests:

 

The Leave packet has a destination address of 0xFFFD, which is one of the broadcast modes, sending the message to all non-sleeping nodes on the network. On the sniffer logs you provided, this address is instead 0x0000.

 

I attached a sniffer log of the test performed on my side.

 

Best regards,

Sebastian

0 Kudos
918 Views
seunghokims
Contributor III

Hi,Sebastian


I know too.
there is no problem with Jn5169.

And with the Zigbee Pro (AN-1223), Ember are no problem.

Only, ....  Problems occur in Zigbee 3.0 (An-1216 & An-1217).

The problem is that Zigbee 3.0 does not receive the Ember Zigbee Leave event.

The problem is very serious.

- Our product is a wall pad with HomeAutomation1.2.

 More than 30,000 units have already been sold.

 Ember sensor node is connected to the wall pad.

 We are planning to update Wallpad to Zigbee 3.0.

 However, the leave event is not received when the Ember sensor leaves.

At this time, the only difference between the logs is destination Address 0x0000 and 0xfffd.

Best regards,

Kim

0 Kudos
918 Views
Sebastian_Del_Rio
NXP TechSupport
NXP TechSupport

Hi Kim,

 

Our devices are certified and comply with the specifications defined by ZigBee Alliance, and our devices work with other compliant devices without issue.

 

I'm really sorry for the inconveniences this may cause, but I would advise you contact Ember support.

 

Best regards,

Sebastian

0 Kudos
918 Views
seunghokims
Contributor III

Hi,Sebastian

The ember sensor is a product of another company.

Our system consists of a coordinator (jn5169), a router(jn5169) and a sensor (Jn5169, Ember, Ti , Etc...).

There is currently no problem with Zigbee Pro (AN-1223).
The problem occurs after Zigbee 3.0 . (Update of coordinator (jn5169) )
When the ember product leaves, no events occur in the Callback function. (In Coordinator)
App_vGenCallBack()
There are no events on the stack. (ZPS_EVENT_NWK_LEAVE_INDICATION)
So guessed.
if the destination address is 0x0000, is it blocked from receiving?
Please tell me how to receive the leave event. (An_1216 or An_1217  should receive)
 

0 Kudos
918 Views
Sebastian_Del_Rio
NXP TechSupport
NXP TechSupport

Hi Kim,

 

Could you please make sure that the Ember device supports and complies with the ZigBee 3.0 Specification?

 

Best regards,

Sebastian

0 Kudos
918 Views
seunghokims
Contributor III

Hi,Sebastian

Unicast is also supported in the ZigBee 3.0 Specification.

I think Adddress(0x0000) should be able to receive.

Is it correct to receive only  0xfffd?

Leave Frame Control Filed.png

Best regards,

Kim

0 Kudos
918 Views
Sebastian_Del_Rio
NXP TechSupport
NXP TechSupport

Hi Kim,

 

Unicast is one of the features supported in ZigBee 3.0, and is implemented in the NXP JN516x ZigBee 3.0 Stack.

 

The problem could be related to the Ember device not supporting ZigBee 3.0, thus not generating the leave network event properly.

 

Best regards,

Sebastian

0 Kudos
920 Views
seunghokims
Contributor III

Hi,Sebastian

The NXP JN516x ZigBee 3.0 Stack does not seem to have received the Leave command in the NWK command frame in unicast.

Looking at the sniffer log I provided, Ember device follows the ZigBee specification.  (AN-1216-ControlBridge&Ember.subx.zip)

-  Could there be something other than what is shown in the sniffer log?

Please test with this function in Jn5169.
- ZPS_eAplZdoLeaveNetwork(0,0,0);

- Test it by changing the Destination address from 0xfffd to 0x0000.

different.png

Best regards,

Kim

0 Kudos
919 Views
Garabo
NXP TechSupport
NXP TechSupport

Hi Kim,
The inconvenience we see here is that your Ember device seems to be not fully compatible with V3. You need to confirm to us that it is able to connect with V3. Our device is 100% compatible with V3 as our certificate shows (https://zigbeealliance.org/zigbee_products/nxp-jn516x-zbpro-r22/). From this point, there is nothing else we can do to help to debug your Ember device. Please report this issue with the manufacturer.

Best Regards,

Garabo

0 Kudos
920 Views
Sebastian_Del_Rio
NXP TechSupport
NXP TechSupport

Hi Kim, I hope you're doing well!

 

Could you please provide the full sniffer log from network creation, to the moment you issue the leave request?

 

If I'm understanding correctly, the issue does not happen if you use a JN5169 as an End Device instead of the Ember ZigBee?

 

Best regards,

Sebastian

0 Kudos