Reports not getting delivered from jn5169

cancel
Showing results for 
Search instead for 
Did you mean: 

Reports not getting delivered from jn5169

885 Views
augustbering
Contributor II

I'm trying to deliver some reports on SupplyStatus and MeterStatus from my application based on the LightSensor sample. I've tried setting it up something like this:

report->u16ClusterID=SE_CLUSTER_ID_SIMPLE_METERING;
report->sAttributeReportingConfigurationRecord.eAttributeDataType = E_ZCL_BMAP8;
report->sAttributeReportingConfigurationRecord.u16AttributeEnum = E_CLD_SM_ATTR_ID_SUPPLY_STATUS;
report->sAttributeReportingConfigurationRecord.u16MaximumReportingInterval=HA_SYSTEM_MAX_REPORT_INTERVAL;
report->sAttributeReportingConfigurationRecord.u16MinimumReportingInterval=HA_SYSTEM_MIN_REPORT_INTERVAL;
report->sAttributeReportingConfigurationRecord.u16TimeoutPeriodField=0;
report->sAttributeReportingConfigurationRecord.u8DirectionIsReceived=0;
report->sAttributeReportingConfigurationRecord.uAttributeReportableChange.zuint8ReportableChange=1;

but don't get any reports. It reports the instantaneous power and energy summation attributes just right, and I can't see any difference in my setup for those attributes.

Labels (1)
Tags (1)
6 Replies

356 Views
ovidiu_usturoi
NXP Employee
NXP Employee

Hi August,

Did you added the new attribute configuration in function vLoadDefaultConfigForReportable?

If not, please consider that the reportable flag is set in function vMakeSupportedAttributesReportable, where the eZCL_CreateLocalReport is called.

Regards,

Ovidiu

0 Kudos

356 Views
augustbering
Contributor II

Yes I did.

356 Views
ovidiu_usturoi
NXP Employee
NXP Employee

Hi August,

I did a similar setup and in my case the reports works as expected.

You should note that the SupplyStatus is an optional attribute. To be enabled, the following define should be in zcl_options.h:

   #define CLD_SM_ATTR_SUPPLY_STATUS

Other observation is the attribute data type:  that is E_ZCL_ENUM8 and not E_ZCL_BMAP8 as I can see in your report configuration.

You can also validate the attribute report configuration by using ReadReportingConfiguration command as below:

- ZGWUI interface:

pastedImage_6.png

- over the air log:

pastedImage_5.png

Let me know if you need more details,

Ovidiu

0 Kudos

356 Views
augustbering
Contributor II

Thanks! Actually, it turned out that once I managed to set up the sniffer, the reports are there, it's just the gateway that for some reason doesn't show them. It looks like you're using wireshark to sniff, is there some docs how for to set the up with the jennic sniffer running on a serial port on a jn516x? 

0 Kudos

356 Views
ovidiu_usturoi
NXP Employee
NXP Employee

Hi August,

Regarding your request to use JN516x sniffer with Wireshark, please see the following community topic:https://community.nxp.com/thread/467817.

Hope that help.

Regards,

Ovidiu

356 Views
ovidiu_usturoi
NXP Employee
NXP Employee

Hi August,

I'm not aware about an official version for JN516x.

In my case, I'm using Kinetis Protocol analyzer, that works with KW2x, Kw4x MCUs.

(for more details, please see below some links:

- Using the Kinetis Protocol Analyzer Adapter with Multiple USB-KW40Z BLE Sniffers 

- https://community.nxp.com/thread/331972 )

Regards,

Ovidiu

0 Kudos