"RTNETLINK answers: Operation not supported" when trying to add a bridge device

cancel
Showing results for 
Search instead for 
Did you mean: 

"RTNETLINK answers: Operation not supported" when trying to add a bridge device

Jump to solution
13,659 Views
bipin_nair
Contributor I

Hello. I am using a version of build_t4240rdb-64b But with the following additional options in the file pointed to by KERNEL_DEFCONFIG

CONFIG_NET_IP_TUNNEL=y
CONFIG_INET_XFRM_TUNNEL=y
CONFIG_INET_TUNNEL=y
CONFIG_INET_XFRM_MODE_TUNNEL=y
CONFIG_INET6_XFRM_MODE_TUNNEL=y
CONFIG_TUN=y
CONFIG_NETFILTER_NETLINK=y
CONFIG_NETFILTER_NETLINK_QUEUE=y
CONFIG_NETFILTER_NETLINK_LOG=y
CONFIG_NF_CT_NETLINK=y
CONFIG_SCSI_NETLINK=y
CONFIG_IP_ADVANCED_ROUTER=y
CONFIG_NET_SCH_INGRESS=y
CONFIG_NET_SCHED=y
CONFIG_IP_MULTIPLE_TABLES=y
CONFIG_NETFILTER_XT_TARGET_MARK=y

After bringing up the image I am now trying to add a bridge device, but I get -

root@t4240rdb:~# ip link add name br0 type bridge
RTNETLINK answers: Operation not supported

Please let me know what configuration option I am missing.

Thanks a lot,

Elliot

Labels (1)
Tags (1)
0 Kudos
1 Solution
11,885 Views
yipingwang
NXP TechSupport
NXP TechSupport

Hello Elliot Black,

Please Enable Ethernet bridging in linux kernel as the following.

[*] Networking support  --->
 Networking options  --->
  <*> 802.1d Ethernet Bridging
  [*]   IGMP/MLD snooping (NEW)

Please refer to the following Kernel options.

root@t2080rdb:~#  zcat /proc/config.gz | grep BRIDGE
CONFIG_BRIDGE_NETFILTER=m
# CONFIG_BRIDGE_NF_EBTABLES is not set
CONFIG_BRIDGE=y
CONFIG_BRIDGE_IGMP_SNOOPING=y

In addition, you also could refer to the following commands to setup bridge.

ifconfig eth0 down
ifconfig eth1 down
brctl addbr br0
brctl addif br0 eth0
brctl addif br0 eth1
ifconfig br0 192.85.1.100


Have a great day,
TIC

-------------------------------------------------------------------------------
Note:
- If this post answers your question, please click the "Mark Correct" button. Thank you!

- We are following threads for 7 weeks after the last post, later replies are ignored
Please open a new thread and refer to the closed one, if you have a related question at a later point in time.
-------------------------------------------------------------------------------

View solution in original post

0 Kudos
2 Replies
11,886 Views
yipingwang
NXP TechSupport
NXP TechSupport

Hello Elliot Black,

Please Enable Ethernet bridging in linux kernel as the following.

[*] Networking support  --->
 Networking options  --->
  <*> 802.1d Ethernet Bridging
  [*]   IGMP/MLD snooping (NEW)

Please refer to the following Kernel options.

root@t2080rdb:~#  zcat /proc/config.gz | grep BRIDGE
CONFIG_BRIDGE_NETFILTER=m
# CONFIG_BRIDGE_NF_EBTABLES is not set
CONFIG_BRIDGE=y
CONFIG_BRIDGE_IGMP_SNOOPING=y

In addition, you also could refer to the following commands to setup bridge.

ifconfig eth0 down
ifconfig eth1 down
brctl addbr br0
brctl addif br0 eth0
brctl addif br0 eth1
ifconfig br0 192.85.1.100


Have a great day,
TIC

-------------------------------------------------------------------------------
Note:
- If this post answers your question, please click the "Mark Correct" button. Thank you!

- We are following threads for 7 weeks after the last post, later replies are ignored
Please open a new thread and refer to the closed one, if you have a related question at a later point in time.
-------------------------------------------------------------------------------

0 Kudos
11,882 Views
bipin_nair
Contributor I

After adding the following configuration options to my CONFIG file I recompiled the kernel and the linux image with the following commands  -
bitbake -c cleansstate virtual/kernel

bitbake -f virtual/kernel -c compile

bitbake virtual/kernel

bitbake fsl-image-full

and I am able boot the image and create a bridge device with the following command -

brctl addbr br0.

Thank you.

0 Kudos