T1040 VLAN issue

cancel
Showing results for 
Search instead for 
Did you mean: 

T1040 VLAN issue

144 Views
Contributor IV

Using the vconfig  command we set up vlan inet interface atT1040 board. The following commands were used:

ifconfig fm1-gb4 0.0.0.0 up

vconfig add fm1-gb4 4080        #Creates fm1-gb4.4080, which is a vlan device with tpid=0x8100

ifconfig fm1-gb4.4080 1.0.0.1 up

If we ping from a PC connected to T1040 fm1-gb4 LAN port the tcpdump shows that VLAN tagged packets are received, see:

root@t1040rdb:/flashfs/Peter# tcpdump -s0 -XX -i fm1-gb4

tcpdump: WARNING: fm1-gb4: no IPv4 address assigned

tcpdump: verbose output suppressed, use -v or -vv for full protocol decode

listening on fm1-gb4, link-type EN10MB (Ethernet), capture size 65535 bytes

10:26:46.154909 ARP, Request who-has 1.0.0.1 tell 1.0.0.2, length 46

        0x0000:  ffff ffff ffff 001b 2181 0ad3 8100 0ff0  ........!.......

        0x0010:  0806 0001 0800 0604 0001 001b 2181 0ad3  ............!...

        0x0020:  0100 0002 0000 0000 0000 0100 0001 0000  ................

        0x0030:  0000 0000 0000 0000 0000 0000 0000 0000  ................

10:26:47.156905 ARP, Request who-has 1.0.0.1 tell 1.0.0.2, length 46

        0x0000:  ffff ffff ffff 001b 2181 0ad3 8100 0ff0  ........!.......

        0x0010:  0806 0001 0800 0604 0001 001b 2181 0ad3  ............!...

        0x0020:  0100 0002 0000 0000 0000 0100 0001 0000  ................

        0x0030:  0000 0000 0000 0000 0000 0000 0000 0000  ................

The RX packet counter of of fm1-gb4 increase but the RX packet counter of fm1-gb4.4080 does not increase.

What can cause this?

Labels (1)
0 Kudos
0 Replies