Problem in receiving multiple frames

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Problem in receiving multiple frames

Jump to solution
925 Views
pankajprasad100
Contributor III

Hi @namnguyenviet ,

I am working on LIN diagnostics in which I have used ld_receive_message and got the data which is of single frame.

But when I sent the MULTIPLE FRAMES for SID-0x34 then I can see the data on the LIN bus but the receiving buffer is not updated.

 

While debugging I got to know data is coming in the descriptor but due to LD_NO_DATA  in rx_msg_status the buffers are not updating.

pankajprasad100_0-1646723423362.png

pankajprasad100_1-1646723620314.png

 

Any suggestions to receive the data would be highly appreciated.

 

MCU-S32K116

COMPILER-IAR

ANALYZER-PLIN

0 Kudos
1 Solution
898 Views
namnguyenviet
NXP Employee
NXP Employee

Hello,

namnguyenviet_5-1647253823852.jpeg

After received diagnostic request, the slave node responded with a negative response. That mean the slave dose not support this request(SID=0x34) and the data will be not updated in data buffer. So, please recheck the configuration to make sure that the SID has been supported.

Regarding using the UDS service, I have an example to implement the UDS frame base on SDK LIN stack release 4.0.2. Hope it can help to you.

On S32DS:

  1. On S32DS:
  • Tick on Use Transport Layer and Support Diagnostic Service.
  • Choose diagnostic class 3
  • Set the max message length corresponding.
  • Tick to use and configured UDS

namnguyenviet_1-1647253796212.jpeg

namnguyenviet_2-1647253796236.jpeg

  1. The configuration files is generated
  • lin_cfg.c

namnguyenviet_3-1647253796250.jpeg

  • Lin_cfg.h

namnguyenviet_4-1647253796259.jpeg

Best Regards,

Nam

View solution in original post

0 Kudos
2 Replies
899 Views
namnguyenviet
NXP Employee
NXP Employee

Hello,

namnguyenviet_5-1647253823852.jpeg

After received diagnostic request, the slave node responded with a negative response. That mean the slave dose not support this request(SID=0x34) and the data will be not updated in data buffer. So, please recheck the configuration to make sure that the SID has been supported.

Regarding using the UDS service, I have an example to implement the UDS frame base on SDK LIN stack release 4.0.2. Hope it can help to you.

On S32DS:

  1. On S32DS:
  • Tick on Use Transport Layer and Support Diagnostic Service.
  • Choose diagnostic class 3
  • Set the max message length corresponding.
  • Tick to use and configured UDS

namnguyenviet_1-1647253796212.jpeg

namnguyenviet_2-1647253796236.jpeg

  1. The configuration files is generated
  • lin_cfg.c

namnguyenviet_3-1647253796250.jpeg

  • Lin_cfg.h

namnguyenviet_4-1647253796259.jpeg

Best Regards,

Nam

0 Kudos
885 Views
pankajprasad100
Contributor III

Thanks, it worked

0 Kudos