S32 doesn't boot

Showing results for 
Search instead for 
Did you mean: 

S32 doesn't boot

Contributor I

I am booting S32G from SD Card. Yesterday everything was working fine.

Today when I started the Eval-board I got the following error:

U-Boot 2018.07

CPU: NXP S32G274A rev. 1.0.1
Reset cause: Power-On Reset
Model: NXP S32G27x
Board: NXP S32G274A-EVB
I2C: ready
DRAM: ddrss: 1D firmware execution failed!
### ERROR ### Please RESET the board ###

I tried to unscrew and screw again the Soc, but keep receiving the same error message.

I tried also to replace the Soc with a CAT2 Soc (The first one was a CAT1), but then I received no output

Can anybody help on this issue, is there any way to debug the Problem ?

0 Kudos
1 Reply

NXP TechSupport
NXP TechSupport

This message is output by DDR controller driver and indicates that DDR interface training failed. This process is done by the embedded calibration processor and is fully automatic. What you can do is:

  • Check that all jumpers are at their default positions. Refer to the board User Guide.
  • Re-program the boot SD card, in case the boot binaries are corrupt.
  • Run diagnostic tests which are available under S32G2 Reference Software category.

If the problem persists or the diagnostic tests find any errors, the board may be permanently damaged.


Best Regards,



0 Kudos