TBDML Problems with CW Debugger

Showing results for 
Search instead for 
Did you mean: 

TBDML Problems with CW Debugger

Contributor I
This message contains an entire topic ported from a separate forum. The original message and all replies are in this single message. We have seeded this new forum with selected information that we expect will be of value to you as you search for answers to your questions.
Posted: Mon Sep 05, 2005 6:52 pm    

I just completed the assembly of the TBDML and everything worked fine until I started to load a small sample program into my HCS12C32 docking module using the CW Debugger. I followed the instructions in the manual and the TBDML HCS12 entry in the main menu appears. The TBDML seems to respond nominally but I always get a load verification failure at $FFFE. I tried this both in boot and in run mode: the same thing happens.

Maybe somebody could provide me with a step-by-step instruction of how to get my code running on the C32 target using the TBDML. Unfortunately the manual stops pretty much at the point where I am at right now.

Posted: Tue Sep 06, 2005 9:51 am    

Did you remember to tell CW to download to NV memory int he load window? I made that mistake.

Posted: Wed Sep 07, 2005 3:09 pm    

this option is greyed out and I see no way to enable it.

Instead I tried the ready-to-use CW stationery for the HCS12C32. All inclusive, compiles perfectly (I set it up for non-banked Flash build target). The program is not supposed to do anything but loop indefinitely. I invoke the Debugger (F5), TBDML already selected, the Debugger tries to flash the MCU, but fails already at the first byte, at address 0x4000.

Could anyone maybe check this out?!

Posted: Thu Sep 08, 2005 4:55 am    


What if you try and flash via the flash menu in ther TBDML menu, does this work?


Posted: Thu Sep 08, 2005 12:18 pm    


which TBDML menu do you mean? The one in the debugger? There is no 'Flash' item Sad

As for my last post; I figured out that there is no flash at address $4000 on the C32; it is blank space. I made the adjustments to the linker file, but the same error persists, this time for address $C000.

Posted: Thu Sep 08, 2005 3:45 pm


I have only used it with the mc9hcs12ne64 but with this one i get a menu point in the TBDML menu called flash. i wonder if it has detected the target proberly.


0 Kudos
0 Replies