Have I bricked my Devkit MPC5748G?

Showing results for 
Search instead for 
Did you mean: 

Have I bricked my Devkit MPC5748G?

Contributor I


I used PE PROGPPCNEXUS to program my customer's s19 file.
I had made a mistake, cut down the power during flash programming.

After that, I got the message below from S32 studio.
"The target may have entered reset escalation. Please power cycle the board".
I have read some articles abort this message on the community.
But I still want to make sure my board is not accessible again or not.
If it does not work again, it is so bad. I need replace the new chip on the board.

I tried to recover the device. Here are my steps.
1) I held reset button before power on.
2) Then controlled the external power and used "pegdbserver_power_console.exe" to send data during 300ms after power on.

But it still do not work. Please see the attachment.



0 Kudos
1 Reply

NXP TechSupport
NXP TechSupport

I suppose you have tried what is stated in the following thread:



I haven't tried it indeed. Don't you have Lauterbach debugger available somewhere around? There is a nice feature for connection just after POR that is pretty simple to use and unlock the device if is is just reset escalation issue.


Haven't you programming UTEST memory? If yes, there is certain probability the device is bricked-up and it'll not be possible to recover. If you were touching only "ordinary" internal flash portion, is should be possible to attach just after POR and erase flash memory.

0 Kudos