What IDE shall be used with LPC54608 development board?

cancel
Showing results for 
Search instead for 
Did you mean: 

What IDE shall be used with LPC54608 development board?

243 Views
chelsauelvispet
Contributor I

I have installed also LPCXpresso IDE and also MCUXpresso IDE and in both of them there is no LPC54608 MCU supported. I checked also for updates, and there is none, but still no LPC54608. Why is not supported by default? I suppose that there should be some sdk files maybe that should be imported. Can you please guide me on what shall I do to have IDE ready for new application? thanks in advance.

0 Kudos
2 Replies

106 Views
robjansen
Contributor III

Like LPCX Support suggests, download MCUXpresso IDE and also create an LPC54608 SDK on https://mcuxpresso.nxp.com. The SDK for LPCXpresso54608 is available as a direct download.

Just drag & drop the SDK_.zip file in the "installed SDKs" pane to install it.

From the quickstart panel you can now import the SDK examples if you like. When creating a new project, select your processor in the same way as with LPCXpresso (project properties, C/C++ Build -> MCU settings). The 54608 can be found in the "SDK MCUs"section.

Rob

0 Kudos

106 Views
lpcxpresso_supp
NXP Employee
NXP Employee

LPCXpresso IDE contains no support for LPC54608. The MCUXpresso IDE supports this part through the installation of an SDK. You'll need to login to mcuxpresso.nxp.com, and request an LPC54608 SDK. You'll be e-mailed once the SDK Builder readies the SDK archive for download.

For more details of installing and using SDKs, please see the MCUXpresso IDE User Guide supplied with the product, or downloadable from the Documentation tab of http://www.nxp.com/mcuxpresso/ide.

Thanks and regards

0 Kudos