Feature Request: Update MCUXpresso should migrate SDKs and update them automatically

cancel
Showing results for 
Search instead for 
Did you mean: 

Feature Request: Update MCUXpresso should migrate SDKs and update them automatically

193 Views
danielholala
Contributor IV

Hello NXP,

I just upgraded to a new major product release (11.4.0) which requires a full product installation.

To keep my development work, I pointed the new release to my previous workspace. That works fine.

However, all SDKs are gone.

Installed SDKsInstalled SDKs

The "MCUXpresso IDE Installation Guide" suggests that I manually import these SDKs from the installation directory of the previous IDE version:

"If you have installed additional plugins into your original IDE installation, then you can also import these. To do this, from your new installation select File -> Import -> Install -> From Existing Installation and point at the ide directory within your original IDE’s installation directory. Note: 
that on macOS / Linux – this option will effectively run automatically the first time you run the new version of the IDE."

Seems this process is simplified on Linux and Mac but not yet on Windows. 

It would be nice to have an automatic migration of SDKs on Windows, too. 

I suggest that during migration, the user if offered to also update to a newer version of the SDK that may be available for use with the newer version of the IDE.

 

0 Kudos
1 Reply

167 Views
lpcxpresso_supp
NXP Employee
NXP Employee

It would be nice to have an automatic migration of SDKs on Windows, too.

Thank you for your suggestion. It makes sense but this is currently an Eclipse stock feature and we currently depend on the upstream work. We'll see if there's a low hanging fruit here... 

I suggest that during migration, the user if offered to also update to a newer version of the SDK that may be available for use with the newer version of the IDE.

We'll follow-up on this. Logged it as a feature request.

Greetings,
MCUXpresso IDE Support