Incorrect values for rms current and injection current

cancel
Showing results for 
Search instead for 
Did you mean: 

Incorrect values for rms current and injection current

443 Views
gianveglio
Contributor I

I have just installed Motor Suite.

When I run it the motor current starts off as 23xxxxxx - some large no. This can be changed to a reasonable current.  But then when I try to measure the motor I get this.

BrakeParams['DCInjCurrent'] set to 650538254336

Although I can change the alue in protection it is not saved and whenever I try to measure I get a huge number and the same error condition.

Has anybody come across this before.  I have reinstalled a few times.  Oh, the motor does run if you bypass the various checks.

KMS_1.1.0 and Kinetis Design Studio.

Some very helpful person, VB, said that you have to change your region to United States. Something in the Python script goes wrong if your region is South Africa.  Quite frankly, I don't know how on earth anybody would find that out!

Labels (1)
0 Kudos
2 Replies

224 Views
linestream-adam
Senior Contributor I

The Python scripts inside KMS can have issues with certain language settings inside Windows.  Obviously we can't test all combinations :smileyhappy:

The key is the decimal separator.  It should be set to .

You can change this in the following dialog:

2017-08-04 08_27_13-C_C++ - KMS-Release@TWRKV31F120M_SNLESSHALL_KDS_[Targets]_[exe] TWRKV31F120M_SNL.png

In the Control Panel, open "Region and Language", click on "Additional Settings" and change your decimal symbol to .

If you can send us screenshots of what your existing settings are we can be sure to add that into our testing.

0 Kudos

224 Views
gianveglio
Contributor I

Hi Adam

Thanks for the reply. It was quite a relief to get things working.

There aren’t many people in South Africa using this so local help is in short supply.

Bye

Gian

0 Kudos