UART0 - BDM Interaction?

cancel
Showing results for 
Search instead for 
Did you mean: 

UART0 - BDM Interaction?

197 Views
Contributor II

We are trying to debug a communications interface with the Multilink FX debugger.  When we stop and start the debugger, the communications interface seems to get lost - like it is digging out of the   This UART is configured with a FIFO of 8 values deep with the receive watermark interrupt set to 1.

The other interesting issue is that if we try to run this UART to send and receive data and the debugger is attached to provide data to Freemaster through the BDM interface, the micro stops running shortly after Freemaster is started running.  If there is no communications on this port (UART0), all works fine - the micro continues to run and data is communicated to Freemaster through the BDM interface.

The UART is UART0 of a K22FN128VLL10 micro.

It seems like there is some interaction - does the BDM use part of UART0 on this micro?

Labels (1)
0 Kudos
1 Reply

58 Views
NXP TechSupport
NXP TechSupport

Hi Douglas,

I did a same test on my board. I didn't see such a problem. The BDM Communication Plug-in enables a basic memory access operations to be performed by the FreeMASTER with the HCS08, HC12/HCS12/X, ColdFire and Kinetis platforms without any target CPU intervention. It use Jtag/SWD port. It don't need UART.

I think your problem may caused by unstable connection. Or maybe you can try to adjust some connection or reading settings in Freemaster.

Regards,

Jing

0 Kudos