MC56F8037 static bootloader

Showing results for 
Show  only  | Search instead for 
Did you mean: 

MC56F8037 static bootloader

Contributor I

Need some help please:


I'm trying to get the static-bootloader working with my MC56F8037 design.

I've followed the instructions in AN3814.PDF.

I'm able to use the static-bootloadeer processor expert project to build and program the bootloader onto the 8037 on my target board.

I modified my target application per the instructions in AN3814.

I'm able to power up the system and use Windowss hyperterminal to send the s-record file for my application and it programs and runs OK.

Hyperterminal output looks like this when it is programming the flash:

    MC56F800x/1x/2x/3x Serial Bootloader v2.0
   Waiting for application S-Record.
   Download Complete
   Lock Flash?
   Application started!


So-far so good, everything seems to be working.  My application is running.


Where I run into problems is when I go back into CodeWarrior and processor expert to continue working on my project.  When I use the USB-TAP to download my code it runs under the debugger OK.

If I power down and back up I expect the static-bootloader to run and then jump to my  application but instead it just appears to hang up.

It acts like loading my application with the USB-TAP is erasing the bootloader.

I went back to the static-bootloader project and re-programmed it into the 8037.  Still no luck.  It almost seems like programming either the  bootloader or my application erases the other when loaded.


Any ideas on how to deal with this?



Labels (1)
Tags (2)
0 Kudos
1 Reply

NXP Employee
NXP Employee

Yes, the IDE will errase the part.  If you wish to protect the flash, try locking it.

0 Kudos