Vishal S

Unable to connect USBTAP - CCSProtocolPlugin::Could not connect to requested core core#0

Discussion created by Vishal S on Mar 16, 2011
Latest reply on Apr 2, 2012 by David Olave

Hi,

 

I have a MPC8313 Rev C board which has a e300 core. I installed Codewarrior EPCC v8.8 IDE v 5.9.0 build 2489 on a Ubuntu 9.04 Linux machine and have a 30 day evaluation period for the Platform edition.

 

I connected the USB TAP correctly on the board and am seeing the TX/RX LED switch ON and OFF at approx 1 Hz rate.The USB TAP is also correctly enumerated as doing a "lsusb" gives the following response

 

root@matrix:~# lsusb
Bus 001 Device 004: ID 15a2:50b3 Freescale Semiconductor, Inc.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 003: ID 046d:c018 Logitech, Inc. Optical Wheel Mouse
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
root@matrix:~#

 

I created a sample helloworld.mcp using the Project Wizard and have compiled it successfully.

 

Now while trying to debug using the USB TAP I am facing the following error message -

" CCSProtocolPlugin::Could not connect to requested core core#0"

 

On taking a dump of the protocol log I see the following messages

 

CCS: 0000    :    ccs_open
CCS:        :        ipaddr = 127.0.0.1
CCS:        :        port = 41475
CCS:        :        timeout = 10
CCS:        :        serverh = 0
CCS:        :    ccs_open; ccs_error = 10
CCS:        :        Error message:
Connection refused

CCS: 0000    :    ccs_open
CCS:        :        ipaddr = 127.0.0.1
CCS:        :        port = 41475
CCS:        :        timeout = 10
CCS:        :        serverh = 0
CCS:        :    ccs_open; ccs_error = 10
CCS:        :        Error message:
Connection refused

CCS: 0000    :    ccs_open
CCS:        :        ipaddr = 127.0.0.1
CCS:        :        port = 41475
CCS:        :        timeout = 10
CCS:        :        serverh = 0
CCS:        :    ccs_open; ccs_error = 0
CCS: 0000    :    ccs_get_connection_count
CCS:        :        serverh = 0
CCS:        :        count = 1
CCS:        :    ccs_get_connection_count; ccs_error = 0
CCS: 0000    :    ccs_available_connections
CCS:        :        serverh = 0
CCS:        :        count = 0
CCS:        :    ccs_available_connections; ccs_error = 0
CCS: 0000    :    ccs_available_connections
CCS:        :        serverh = 0
CCS:        :        count = 0
CCS:        :    ccs_available_connections; ccs_error = 0
CCS: 0000    :    ccs_config_cc
CCS:        :        serverh = 0
CCS:        :        config_string = utap:0
CCS:        :    ccs_config_cc; ccs_error = 0
CCS: 0000    :    ccs_available_connections
CCS:        :        serverh = 0
CCS:        :        count = 1
CCS:        :    ccs_available_connections; ccs_error = 0
CCS: 0000    :    ccs_available_connections
CCS:        :        serverh = 0
CCS:        :        count = 1
CCS:        :    ccs_available_connections; ccs_error = 0
CCS: 0000    :    ccs_set_timeout
CCS:        :        serverh = 0
CCS:        :        timeout = 10
CCS:        :    ccs_set_timeout; ccs_error = 0
CCS: 0000    :    ccs_config_server
CCS:        :        serverh = 0
CCS:        :        cc = 0
CCS:        :        server_config = 0
CCS:        :        value = 1000
CCS:        :    ccs_config_server; ccs_error = 25
CCS:        :        Error message:
USB open failure

CCS: 0000    :    ccs_get_config_chain
CCS:        :        serverh = 0
CCS:        :        device_list: (size = 0)
CCS:        :    ccs_get_config_chain; ccs_error = 25
CCS:        :        Error message:
USB open failure

CCS: 0000    :    ccs_kill_server
CCS:        :        serverh = 0
CCS:        :    ccs_kill_server; ccs_error = 0
CCS: 0000    :    ccs_delete_cc
CCS:        :        serverh = 0
CCS:        :        count = 0
CCS:        :    ccs_delete_cc; ccs_error = 7
CCS:        :        Error message:
Invalid handle

CCS: 0000    :    ccs_close
CCS:        :        serverh = 0
CCS:        :    ccs_close; ccs_error = 0

 

I also see a print in the terminal window which says

 

"Please check your JTAG clock speed."

 

The JTAG clock speed as of now is 4.03 MHz. I have tried changing it to 1 MHz but still the connection fails.

 

Can someone help me in connecting the Codewarrior USB TAP to the board ?


Outcomes