Chris Nowak

CW ColdFire 7.2. Eval "ColdFire gdi Protocol Adapter: can't connect"

Discussion created by Chris Nowak on Mar 7, 2011
Latest reply on Jun 3, 2011 by Murat Gunal

Hello everyone, this is my first post on this forum, unfortunately already with a problem.

 

I seem to be experiencing the same problem as the one mentioned in this thread, only this one is with CW 7.2. Coldfire.

 

I'm trying to use M52259DEMOMCU which I received last week. Since the CD that is attached to the package is being held by the person who ordered the board and sent it to me, I downloaded the CW_ColdFire_7.2_Eval and pateches 7.2.1 and 7.2.2.  I also installed FSLMQXOS_3_6_2 and tried to connect the board with the bootloader cable.

 

The problem is, everytime I want to go "by the book" (i.e. like the Quick Guide says) and I come to the point where I am either to run I get the same message:  ColdFire gdi Protocol Adapter: can't connect; when I try to erase flash, I get Error: Can't connect.

 

I checked all the threads I could find to try and apply found solutions, but to no avail.

When I try to use the JM60 USB GUI to connect with the board, I can't and it shows that I am not connected by USB bootloader.

 

I tried installing different USB drivers, even downloaded them from Pemicro, but it doesn't seem to help. The device shows it has proper drivers installed and that it is working properly, which it obviously is not. (current drivers data is: LibUSB-Win32 Devices, date 2008-08-15, driver version 0.1.12.1)

 

I'm using Win7 32-bit, I also tried it on another PC with Win XP 32-bit.

 

If anyone has any piece of advice on how to overcome this problem, please help, I would be grateful.

Outcomes