AnsweredAssumed Answered

TWR-K60N512 Quick Start Demo -- Not working

Question asked by Timothy James Telan on Feb 6, 2011
Latest reply on Feb 7, 2011 by Timothy James Telan

Let me start by saying this is my first time working with the Kinetis and the Tower system.

 

I'm working on my senior project and this is also the first time I have to set up my own development environment.

------------

 

So, I am trying to go through the Quick Start Demo lab (v1.2).

  • I've reconfigured the jumpers to match the assignments in section 2
  • I played around with the touch demo, the memory game, and the accelerometer demo (in standalone).
  • After some driver trouble, I was able to install the PE Micro tower toolkit  and followed with the terminal demo (using the toolkit software).
  • Didn't have an SD card, so I didn't test that demo.
  • USB Mouse demo did not work for me.
  • Web server demo worked well.

------------

Now for the software and programming (section 4)

 

  • I installed IAR for ARM v6.10 (eval) and MQX 3.6.2.
  • Enabled ESHDC and I2C0 drivers and rebuilt these libraries with changes made accordingly. No errors.
  • Unzipped the demo files to the MQX directory and followed the instructions for opening that project and building.
  • Downloaded the code to the board.

Section 5, Task Aware Debugging, doesn't work. The MQX dropdown menu is all greyed out.

 

Now, at this point, I wasn't sure what was supposed to happen. At the moment, there are only power lights. I can't access the webserver. I'm assuming it is supposed to be the initial demo before I flashed it.

 

Has anyone else gotten this demo to work? I've been going through this quick start walkthrough for a few days now and I can't quite see what I am doing incorrectly.

 

Outcomes