Gu Yan

MCU on EVB9S12XF512E can't be programmed properly

Discussion created by Gu Yan on Aug 30, 2010
Latest reply on Sep 1, 2010 by Gu Yan

After the download, what the debuger look has showed in the attachment.

During the download, some information are showed in the command window:

 

Reset command file correctly executed.
<Timeout> (> 2000 ms)
Program counter: 0x00000063
Block Module Name      Address Range   Status
   0  FLASH_4000        FF00 - 11DFF   Programmed - Unselected
<Timeout> (> 2000 ms)
Program counter: 0x00000063
   1  FLASH_8000        FF00 - 11DFF   Programmed - Unselected
<Timeout> (> 2000 ms)
Program counter: 0x00000063
   2  FLASH_C000        FF00 - 11DFF   Programmed - Unselected
   3  ALL_PPAGES      FFFFFF -1FFFFFD   Skipped - Unselected

FP: The UNPROTECT command is not available for the FLASH_4000 flash module => Skipped.

FP: The UNPROTECT command is not available for the FLASH_8000 flash module => Skipped.

FP: The UNPROTECT command is not available for the FLASH_C000 flash module => Skipped.

FP: Call of a command not implemented!
Please modify "flags" in ALL_PPAGES module INFO applet.
Block Module Name      Address Range   Status
   0  FLASH_4000      FFFFFF -1FFFFFD   Skipped - Selected
   1  FLASH_8000      FFFFFF -1FFFFFD   Skipped - Selected
   2  FLASH_C000      FFFFFF -1FFFFFD   Skipped - Selected
   3  ALL_PPAGES      FFFFFF -1FFFFFD   Skipped - Selected
executing .\cmd\P&E_Multilink_CyclonePro_vppon.cmd

!// Before programming the flash, the commands written below will be executed
done .\cmd\P&E_Multilink_CyclonePro_vppon.cmd

Vppon command file correctly executed.

FP: The ERASE command is not performed for the FLASH_4000 flash module (AEFSKIPERASING) => Skipped.

FP: The ERASE command is not performed for the FLASH_8000 flash module (AEFSKIPERASING) => Skipped.

FP: The ERASE command is not performed for the FLASH_C000 flash module (AEFSKIPERASING) => Skipped.

FP: The ERASE command is not performed for the ALL_PPAGES flash module (AEFSKIPERASING) => Skipped.
executing .\cmd\P&E_Multilink_CyclonePro_vppoff.cmd

 

 

I believe there are something wrong with Flash, because " <Timeout> (> 2000 ms) "showed in the command window in the seconfd line.

I don't know what happened, and MCU is not working as it is supposed to be?

I need your help, please!

Outcomes