Antonio Quevedo

I cannot install CodeWarrior

Discussion created by Antonio Quevedo on Mar 9, 2010
Latest reply on Mar 10, 2010 by Tom Thompson

Hello,

 

I am facing a quite unusual problem related to software installation. I use Freescale tools in undergrad teaching labs, and we could not install CodeWarrior for 8-bit/ColdFire_v1 (version 6.3), downloaded from Freescale website, in one of the computers (running Windows XP SP2). When installation starts, after reading package, an error message appears: "The contents of this file cannot be unpacked. The executable you are attempting to run has been corrupted. Please obtain another copy of the file, verify its integrity, and try again". The same file worked on all computers but that one. I also tried to install the version for ColdFire v2-v4, and got the same error. I do not know what was installed earlier on that computer.

 

Now the funniest part. In my development lab, I was using ColdFire for 8-bit version 6.2. I had to migrate to 6.3 because I wanted to work with the 51CN family. So I uninstalled version 6.2 (in a computer also running windows XP SP2), and after that I tried to install version 6.3. Then I got the same error that appeared in the teaching lab computer. I have tried to re-install version 6.2, and the same error appeared. It seems that after uninstalling one version of CodeWarrior, something happens that prevents the user from installing it again, with an error message that has nothing to do with the real problem (I have re-downloaded the files, not using any download accelerator).

 

Anyone has seen this problem before? How can I fix it? Will I have to re-install everything on my lab computer?

 

Cheers,

Outcomes