AnsweredAssumed Answered

LPC5528 cannot halt processor

Question asked by Rik Vugteveen on Jun 30, 2020
Latest reply on Jun 30, 2020 by Myke Predko

I am working on a project that uses the LPC5528 processor. When starting a debug session i encounter the following issue. 

PopUp

 

Console output:

MCUXpresso IDE RedlinkMulti Driver v11.1 (Feb 24 2020 13:54:38 - crt_emu_cm_redlink build 11)
Found part description in XML file LPC5528_internal.xml
Reconnected to existing LinkServer process.
Using memory from core 0 after searching for a good core
debug interface type = Cortex-M33 (DAP DP ID 6BA02477) over SWD TAP 0
processor type = Cortex-M33 (CPU ID 00000D21) on DAP AP 0
number of h/w breakpoints = 8
number of flash patches = 0
number of h/w watchpoints = 4
Probe(0): Connected&Reset. DpID: 6BA02477. CpuID: 00000D21. Info: <None>
Debug protocol: SWD. RTCK: Disabled. Vector catch: Disabled.
Content of CoreSight Debug ROM(s):
RBASE E00FE000: CID B105100D PID 0000095000 ROM (type 0x1)
ROM 1 E00FF000: CID B105100D PID 04000BB4C9 ROM (type 0x1)
ROM 2 E000E000: CID B105900D PID 04000BBD21 CSt ARM ARMv8-M type 0x0 Misc - Undefined
ROM 2 E0001000: CID B105900D PID 04000BBD21 CSt ARM DWTv2 type 0x0 Misc - Undefined
ROM 2 E0002000: CID B105900D PID 04000BBD21 CSt ARM FPBv2 type 0x0 Misc - Undefined
ROM 2 E0000000: CID B105900D PID 04000BBD21 CSt ARM ITMv2 type 0x43 Trace Source - Bus
ROM 1 E0040000: CID B105900D PID 04000BBD21 CSt type 0x11 Trace Sink - TPIU
NXP: LPC5528
DAP stride is 1024 bytes (256 words)
Inspected v.2 On chip Flash memory using IAP lib LPC55xx.cfx
Image 'LPC55xx Feb 17 2020 13:57:00'
Opening flash driver LPC55xx.cfx
Sending VECTRESET to run flash driver
warning - watchpoint hit but none found set
Flash variant 'LPC55xx (512KB)' detected (512KB = 16*32K at 0x0)
Closing flash driver LPC55xx.cfx
Connected: was_reset=true. was_stopped=false
Awaiting telnet connection to port 3330 ...
GDB nonstop mode enabled
Opening flash driver LPC55xx.cfx (already resident)
Sending VECTRESET to run flash driver
Flash variant 'LPC55xx (512KB)' detected (512KB = 16*32K at 0x0)
Writing 23024 bytes to address 0x00000000 in Flash
Sectors written: 0, unchanged: 1, total: 1
Erased/Wrote sector 0-0 with 23024 bytes in 81msec
Closing flash driver LPC55xx.cfx
Flash Write Done
Flash Program Summary: 23024 bytes in 0.08 seconds (277.58 KB/sec)
Starting execution using system reset and halt target with a stall address
Retask read watchpoint 1 at 0x50000040 to use for boot ROM stall
Waiting for target to stop...
Warning - processor did not halt - gave up waiting
flash - system reset failed - Ep(04). Cannot halt processor.
Target error from Commit Flash write: Ep(04). Cannot halt processor.
GDB stub (crt_emu_cm_redlink) terminating - GDB protocol problem: Pipe has been closed by GDB.

This prevents me from debugging the target on my desktop PC for almost  90% of the time. There are some cases that it does start the debug session correctly. Unfortunately i could not find a solution to maken the debugging more stable on this system. 

 

When is use the same hardware target and debugger on my laptop it works flawless and debugging works like a charm.  

 

On my laptop i have version 11.1.0 of MCUXpresso installed. 

On my desktop i started with version 11.1.1. I also installed the older version 11.1.0 to see if this solved my issue but unfortunately i get the same result. 

Both machines run on windows 10. 

I alsready tried to "Clean up debug" data but this did not resolve my issue. 

 

Any suggestions on how to solve this issue?

Outcomes