AnsweredAssumed Answered

Disabling Default Response when sending attribute report?

Question asked by Pierre-Luc Drouin on Feb 3, 2020
Latest reply on Feb 5, 2020 by Mario Ignacio Castaneda Lopez

Hi,

 

I am trying to disable Default Reponse when sending an attribute report with eZCL_ReportAttribute, but I am unable to get it to work. I have ZCL_DISABLE_DEFAULT_RESPONSES set to TRUE in my zcl_options.h file.

 

I am using a thermostat_device, and I can confirm that sEndPoint.bDisableDefaultReponse is set to TRUE after registering the endpoint using eHA_RegisterThermostatEndPoint. I verified that the value of sEndPoint.bDisableDefaultReponse  does not change at a later stage. However when I send an attribute response using eZCL_ReportAttribute, sniffing the packets show that the Disable Default Response flag is set to FALSE. I also see the Default Response packet from the coordinator, which is then followed by an APS ACK from my device (although I also disabled ZPS ACKs by setting ZCL_DISABLE_APS_ACK to TRUE in my zcl_options.h file). I am working with a JN5169 chipset and the JN-SW-4170 SDK. How can I get it to work?

 

Thanks!

Outcomes