AnsweredAssumed Answered

Emcraft i.MX 8M kit + FRD55, Demo GUI Application don't work

Question asked by Mateusz Salamon on Jan 16, 2020
Latest reply on Jan 16, 2020 by igorpadykov

Hello,

 

I would like display standard demo on display FRD55 using standard code form emcraft repository (https://www.emcraft.com/som/imx-8m/using-mipi-dsi-to-connect-the-frd-55-display-panel).

After the system boots up display is dark, nothing show (backlight work). I check hardware and every power supply is fine. In logs I have the same information like in tutorial (see in attachment).

 

I checked frame buffer set and timings have only 0 value. Is it correct ? Below is data from terminal:

root@imx8m-som:~# fbset

mode "1920x1080"

    geometry 1920 1080 1920 1080 32

    timings 0 0 0 0 0 0 0

    accel true

    rgba 8/16,8/8,8/0,0/0

endmode

 

I tried run lcdtest but effect is the same: display is dark. Below is data from terminal:

root@imx8m-som:~# lcdtest

1920x1080, 32bpp

The framebuffer can be accessed at the address 0xffffa3851000

 

I tried upload frame buffer random data but I got receive, that buffor didn’t left space:

root@imx8m-som:~# > sudo cat /dev/urandom > /dev/fb0

cat: write error: No space left on device

 

Please give me some advice what is wrong,

Attachments

Outcomes