AnsweredAssumed Answered

i.MX6qp Sabre AI cannot boot the validation sdcard image

Question asked by Michal Olbrich on Aug 2, 2019
Latest reply on Aug 7, 2019 by Michal Olbrich

Hello,

I'm using MCIMX6QPAICPU3 board. I want to boot linux from SD card. I set all the S1,S2,S3 according to the configuration.

S1:0100100000, S2:0010, S3:0010, SW3:00

I tried to create a bootable SD card with fsl-image-validation-imx-imx6qpdlsolox.sdcard. I tried both Win32DiskManager and Linux dd command (sudo dd if=fsl-image-validation-imx-imx6qpdlsolox.sdcard of=/dev/sdb bs=1M && sync). None of them  worked. I don't see anything on HDMI nor on serial line.

 

The only progress I have accomplished is, that I was able to run the uboot (u-boot-imx6qpsabreauto_sd.imx), but the uboot was not able to load the rootfs on second partition.(I partitioned the SD card and copied the uboot and the rootfs)

 

...So I know, that the serial line works, and the board works as well.

 

My question is, why it cannot boot validation image fsl-image-validation-imx-imx6qpdlsolox.sdcard ? Is there any aditional step? Because it doesn't seems so from the guide.

I followed the i.MX Linux User Guide precisely.

 

Thank you.

Outcomes